Support » Installing WordPress » Upgrade from 0.72 to 1.0

  • This is based on a few bumps I had tonight. Thanks to the help from the Lizard and the Duck! 🙂
    NOTE: THIS IS AN UPGRADE FROM WP 0.72 to WP 1.0!
    Here’s what I did to get it going:
    1. I unzipped the archive on my local PC.
    2. I took the settings from my backed-up wp-config.php file and manually updated the wp-config-sample.php file.
    3. I deleted all of the WordPress files and folders on my web server AFTER MAKING A COMPLETE BACKUP OF EVERYTHING.
    4. I uploaded all of the new WordPress 1.o files and folders to my web server.
    5. I changed the name of wp-config-sample.php to wp-config.php.
    6. I pointed my browser to /wp-admin/upgrade.php and ran the script.
    7. I loaded up my blog on my browser, and logged in.
    I hope that this helps someone.
    Craig.

Viewing 15 replies - 1 through 15 (of 32 total)
  • Thank you Craig! I will use your help tips when I upgrade today! 🙂

    A nice clear guide. Helped me to roll out a flawless installation. Thanks.

    I had a few bumps. 🙁 I lost all my posts and links they are in my database somewhere, right? Bleck. I’m not really sad, though. *LOL* I had to do a fresh install. Oh well. It’s not pretty, will be a while as all the folders and such have moved.

    Hi all,
    this is my first post, and English is not my mother tongue, so please excuse me if it’s not clear.
    I tried to upgrade from WordPress 0.72 to 1, but it did not work. So I came here and found these “step-by-step” instructions, but I have some problems in understanding them.
    Step 1 is clear 🙂
    Step 2 for example: what do you mean with
    ” my backed-up wp-config.php file and manually updated the wp-config-sample.php file”
    The wp-config.php of version 0.72 and wp-config-sample.php of version 1.0?
    I am asking this, because the files are different.
    Steps 3 and 4 are fine
    Step 5:
    ” I changed the name of wp-config-sample.php to wp-config.php”
    the wp-config-sample.php is the one you edited in step 2?
    You just change the name, so that wp-config-sample.php does not exists anymore?
    Or you have wp-config-sample.php AND wp-config.php? If so, do they have the same contents?
    Steps 6 and 7 are fine too.
    Sorry for being so “obsessive”, but I really would like to upgrade, and the upgrade process was very unlucky.
    Thanks in advance for any reply.
    Dario

    Dario,
    No aplogies necessary. I will try to clarify things for you.
    First of all, not only did I backup my database, but I did a backup of ALL of my WordPress files. These files were copied FROM my web server TO my own computer here at home. Then, once all of the backups were completed, I deleted everything in my WordPress folder on my web server. I didn’t delete my database, of course.
    For Step 2, I opened up the wp-config.php file which I just backed up, because it has all of the necessary information for the database connections. I had previously unzipped all of the new V. 1.0 files onto my hard drive, in a separate folder. I opened the wp-config-sample.php file from that folder, and updated the wp-config-sample.php file to be EXACTLY the same as my backed-up wp-config.php file.
    So, to summarise:
    I have a total WP folder backup.
    From the backup, I openend wp-config.php.
    I copied the necessary information from wp-config.php to the new wp-config-sample.php. Then I upload all of the files to the web server.
    Step 5.
    Now that all of the new WP 1.o files are uploaded, I need to have a wp-config.php file ready when I run the upgrade.php script. The only file on the web server that has the correct information is the wp-config-sample.php which I manually changed in Step 2. I simply renamed the wp-config-sample.php to wp-config.php. This does indeed mean that wp-config-sample.php does NOT exist on my web server. I still have the file locally on my own computer.
    I hope that this helps. If you would like any more clarification, then please do ask, and I’ll do what I can to find or give you an answer!
    Craig.

    I figured it out. 🙂 Thanks Mark!

    Hi Craig,
    thanks a lot for all the details you provided.
    I’ll try to upgrade tomorrow (it’s midnight here right now), following your instructions.
    I will let you know how things go.
    Greetings from Italy.
    Dario

    Hmmm…good thing I tried upgrading a not-yet-rolled out installation first.
    I followed NM’s directions exactly. I had a “clean” install of 0.72. (This is a second install of WP, in a different directory and using a separate DB…the 0.72 test installation was working fine, and had not been moded or hacked in any way.)
    Once I got to the point of running /wp-admin/upgrade.php, here’s what I got:

    Warning: Invalid argument supplied for foreach() in E:\webs\tcervo.com\wwwroot\movies\wp-admin\upgrade-functions.php on line 536
    Warning: Invalid argument supplied for foreach() in E:\webs\tcervo.com\wwwroot\movies\wp-admin\upgrade-functions.php on line 606
    Step 1
    There’s actually only one step. So if you see this, you’re done. Have fun!
    get_settings: Didn’t find setting hack_file

    So, clicking on the Have fun! link takes me to my blog, despite the errors. But, my index page has the following:
    “get_settings: Didn’t find setting comment_allowed_tags”

    Note: the “get_settings: Didn’t find setting comment_allowed_tags” message shows up on EVERY page, including the login page, admin page, etc. (You can see it at the very bottom of the page.)
    You can see it here: http://www.tcervo.com/movies/
    Any ideas? This has me scared to death of upgrading my “real” blog…

    allusion,
    Perfect, that did the trick. I missed that thread the first time around…
    -Tony

    Hi Craig,
    I followed your instructions line by line, but still can not upgrade:
    Warning: main(/home/diludovi/public_html/dario/b2-include/wp-db.php): failed to open stream: No such file or directory in /home/diludovi/public_html/dario/wp-config.php on line 49
    Fatal error: main(): Failed opening required ‘/home/diludovi/public_html/dario/b2-include/wp-db.php’ (include_path=’.:/php/includes:/usr/share/php:/usr/lib/php:/usr/local/lib/php’) in /home/diludovi/public_html/dario/wp-config.php on line 49
    At this point, I think I will wait for version 1.01 to be released…
    Thanks anyway.
    Dario

    Dear wp user, i ask only one information about the upgrading of WP from 0.72 to 1.0.
    I Understand that is better to try the upgrade on a local machine, but when i make this i need to change the index.php that have my own layout or i can use my past file? thanks in advance
    Giovanni

    visualounge, yes it is recommended that you update the index-file as well. There have been changes.

    dariottolo, in version 1.0 all file and dir names have been changed from b2 to wp, so the b2-include directory is now called wp-include, and so on.
    I suspect you haven’t upgraded all files. Check your index file for a start.

    Thanks Craig, I was having a lot of problems with upgrading.. maybe I was thinking in a too complicated way 🙂 Worked perfectly for me, I was done within 10 minutes!
    Now I have to upgrade 2 other blogs from b2 to WordPress :-s

Viewing 15 replies - 1 through 15 (of 32 total)
  • The topic ‘Upgrade from 0.72 to 1.0’ is closed to new replies.