WordPress.org

Support

Support » How-To and Troubleshooting » Upgrade fails silently with Nginx

Upgrade fails silently with Nginx

  • I have no problems with any other aspect of WP, including the upgrade of plugins, using Nginx as a web server. However, when I try the automatic upgrade from 3.52 to 3.6, it goes through all the paces, indicating success at every one, and then completes as if all is well. It even displays the bold 3.6 version welcome. But at the same time, the notification banner is still at the top prompting me to upgrade to 3.6.

    Does anyone have a clue as to what could cause the upgrade to fail yet no errors to show, up front or in the logs? If it helps, when I try the manual upgrade, it never asks me to upgrade the database and acts the same as if I had tried the auto, as if nothing was done. I’m thinking the key is in the database change that isn’t happening, but I can’t be sure without being able to trigger it manually.

    As a work around, is there a manual way to upgrade the database?

    File and folder permissions are set up according to best practice, and work for all other functions. I even tried giving all files and folder write access but it remained the same. Also, it does appear that the files are being replace, just not the database.

    Note: FYI, the nginx vhost I’m using is here. I have tried the one from the WP docs however and come up with the same issue.

    Thanks.

Viewing 1 replies (of 1 total)
Viewing 1 replies (of 1 total)
  • The topic ‘Upgrade fails silently with Nginx’ is closed to new replies.