Support » Installing WordPress » upgrade failed – ‘you dont have permission to access / on this server

  • Resolved wendyhouse


    upgraded from wordpress 2.02 to 2.03
    I can view my blog
    with the new theme.
    I added my previous orcadia theme folder on my ftp server

    but when I try to sign into Admin from the blog pages I get this error

    Fatal error: Call to undefined function: wp_get_current_user() in /home/content/W/e/n/WendyHouse/html/wp-admin/admin.php on line 20


Viewing 7 replies - 1 through 7 (of 7 total)
  • I deleted wp-admin contents from my ftp server and the copied the new WordPress 2.03 wp-admin across (again). I visually confirmed that the contents on the server matched the contents downloaded from your site.

    I deleted the wp-contents cache (I missed doing this on original install)

    I ran http://blog/wp-admin/upgrade.php

    again, just in case…

    I clicked log-in from my blog page and got this error:
    Fatal error: Call to undefined function: wp_get_cookie_login() in /home/content/W/e/n/WendyHouse/html/wp-login.php on line 181


    I deleted to contents of wp-includes on my ftp sever, copied the contents of the worpress 2.03 files to the server, ran the upgrade .php (just in case).

    Successful log-in!

    I’m guessing that some file or other didnt ftp across properly. It’s painful for a novice to diagnose….

    I just had the same problem and reloading new files worked. If I could now just fix the “settings.php’); ?>hp’); ?>” error.

    I had the same issue, it appears that with the new version 2.0.3 files this problem arises when trying to overwrite 2.0.2 wp-includes. I was able to resolve the problem by deleting the wp-includes and installing a fresh one.

    Amazing what happens if you follow the directions ;’)

    1. Delete /wp-admin/ folder.
    2. Delete /wp-includes/ folder.

    Yosemite – I did follow the instructions, I had to repeat the actiuon of deleting the admin folder 2 x to work. As stated, I suspect the FTP process lead to some file corruption. Your comment was unhelpful and unneccessary.

    Not according to your description, it was still broken until you did the wp-includes/.

    Either way, it can’t be stressed enough…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘upgrade failed – ‘you dont have permission to access / on this server’ is closed to new replies.