Upgrade failed, now wp-admin "page not found" error (4 posts)

  1. Mercurial Muroid
    Posted 3 years ago #

    I just attempted to upgrade to WordPress 3.4.2 received a "Missing a critical file" failure. The error was
    "Refresh Failed: status:198|file:/home1/website/public_html/wp-includes/version.php"

    I believe the problem was that I recently moved WordPress from my root directory to a /blog sub-directory following the Codex instructions. It seemed successful, but something was not updated and the upgrade tried to work in the wrong place.

    Now I cannot gain access to to my WP dashboard, and most of my blog contents is missing.

    The only solution I can think of is to uninstall and re-install wordpress; would that work? Is their possibly an easier fix?

  2. What you could do is access your site via FTP and re-upload a fresh copy of WordPress. I would upload all the files from the root directory, the wp-admin and wp-includes. You don't need anything from the wp-content folder.

    Once that's done, hopefully you will be able to access the wp-admin once again.

    Your blog content should be in the database, so shouldn't be affected.

  3. Mercurial Muroid
    Posted 3 years ago #

    Sorry, that didn't work, everything's the same.

  4. Mercurial Muroid
    Posted 3 years ago #

    I've been reading every older thread I could find on this subject.

    I tried renaming and then replacing the Themes and Plugins folders, only got a white screen.

    Checked the version.php, the numbers were all correct.

    I was running Better WP Security (which I have had trouble with before), but disabled it along with all other plugins when I upgraded. On whim I just checked .htaccess and removed the entire # BEGIN Better WP Security section, and I have a dashboard!

    I have no idea why that worked or if what I did was a good thing. Should I reactivate it or find a different security program.

    Any ideas?

Topic Closed

This topic has been closed to new replies.

About this Topic