Support » Installing WordPress » Upgrade failed due to wp-dp error, backup fails as well

  • Hello, I hope someone can help me out…

    Despite the back-up and carefully checking the guide, I think I crushed my private blog when I tried to upgrade to 2.1 from 2.0.4. Short and sweet: The upgrade failed when I tried to run upgrade.php. I deleted the old folders and files except the .htaccess, wp-config.php, wp-content and -images, but deleted the cache and wp-admin folder as it is instructed.

    So I deleted the files and tried to re-upload my back-up.
    The same error as when trying to upgrade appears:

    Warning: main(/www/htdocs/MyAccount/blog/wp-includes/wp-db.php) [function.main]: failed to open stream: Operation not permitted in /www/htdocs/MyAccount/blog/wp-settings.php on line 72

    Fatal error: main() [function.require]: Failed opening required ‘/www/htdocs/MyAccount/blog/wp-includes/wp-db.php’ (include_path=’.:/usr/share/php:..’) in /www/htdocs/MyAccount/blog/wp-settings.php on line 72

    The only difference to the upgrade error is the line – now it’s line 72, the first one was line 102 or alike.

    The line says

    require_once (ABSPATH . WPINC . ‘/wp-db.php’);

    I hardly know PHP, but it looks ok to me, doesn’t it?

    FYI, WordPress shares a database why a gallery, the tables have the prefix “wp_”. After reading one of the posts here, I double checked that the prefix is still the same in the database. Well, it still is the same.

    One topic dealing with such an wp-dp.php error suggests to fix some code in that file … if you changed it, what I didn’t do.

    I also checked the adressed files and wp-config or unneeded spaces before the php tags, like another topic mentioned.

    I used a different FTP client, FileZilla, as described in the documentation. Is there a chance that the program messed up the files? Or is it perhaps known to put the wrong CHMOD values or anything like that? The settings looked fine, though…

    Now I ran out of ideas what else to check. I’d like to bring back my old 2.0.4 version at least.

    Thank you for some input.

Viewing 7 replies - 1 through 7 (of 7 total)
  • I’d delete the files as explained in Upgrading WordPress.

    Then download and unzip 2.1.1 from to get a clean distribution.

    Finally I’d reupload the unzipped 2.1.1 files.

    Of course don’t forget to do the upgrade.php step.


    Note: FileZilla is a good FTP client.

    First off, thank you.
    The problem, though: What you described is what I did 🙁
    I deleted those files mentioned in the paragraph “Delete these Files and Folders”, just kept those mentioned in the “DO NOT DELETE these foldes and files” paragraph.

    I also did quite the opposite – deleted all new files of the 2.1 update, then uploaded my back-up files – and still I’m confronted with that error.

    As I mentioned, the error occurs when I try to run upgrade.php.

    Yes, but when you uploaded your back-up files, did you also uplaod the original distribution of WordPress(2.0.4)?

    Usually, when you create a backup, you’re only backing up the database files, and then the files through FTP (like your plugins and themes). If you upgrade and it fails, then you have to remove the new upgraded files and reupload the old installation/WordPress files. If you just overwrote the old files with the upgraded ones, then deleted them and uploded your backup files, then you’re missing a *lot* of files.

    Man, I hope that made sense. You might have to read it a couple of times to get what I’m saying!

    Oh, you’re making sense, I think. 🙂

    WordPress is located in a folder “(root/)blog/” and I copied the whole blog folder. So to say: I emptied the whole folder, the uploaded the back-up. And you guess it … error.

    Am I right that the database tables were not changed, since the upgrade does not start?
    That’s the only thing I haven’t done yet, replacing the database with the back-up as I assume they stayed the same.

    Status quo: Repeated the whole “delete folder, replace with back-up” routine and got at least my background pic back.

    Decision: Keep the back-up in loving memory of old times and keep on whining about not having a blog to bitch about my shredded blog.

    So long.

    Am I right that the database tables were not changed, since the upgrade does not start?

    No. The database did change between the 2.0.x and 2.1.x series so reuploading you old WP won’t work. You need to re-upload the database too.

    Shouldn’t a database change require the upgrade script to happen?

    The script never ran, so in theory, the database should have stayed the same.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Upgrade failed due to wp-dp error, backup fails as well’ is closed to new replies.