Support » Installing WordPress » Upgrade error, need help.

  • Resolved Rupan

    (@rupan)


    After replacing all the necessary files and keeping the config and contents files I tried to upgrade and get:

    Fatal error: Call to undefined function _http_build_query() in ../wp-includes/functions.php on line 583

    the .. is the dir on the webspace. Line 583 of the functions.php is:
    return _http_build_query($data, NULL, ‘&’, ”, false);

    Whats wrong?

Viewing 13 replies - 1 through 13 (of 13 total)
  • try re-uploading everything, keeping your .htaccess, config, data (uploads) and plugin/theme files safe.

    If that fails, re-download and re-upload again. and if THAT doesn’t work, cry lol! Or ask again and someone’ll take a look at it I’m sure!

    I used the same download for a full install of a new blog so I know it’s working. Yea, I am keeping those files safe, still not working 🙁

    have you tried to run upgrade.php?

    if you’re still having problems disable all your plugins from phpMyAdmin, there could be a possibility of them trying to call a removed function

    I’ll try that out. Where exactly in the phpMyAdmin should the plugin info be?

    By the way, yea, I tried to run upgrade.php, thats when I’m getting the problem

    I changed the plugin entrie in phpmyadmin to “a:0:{}” which i presume deactivates the plugins. It didnt fix my current problem

    That function function _http_build_query is in wp-includes/compat.php so at a minimum reupload that file.

    Make sure you are uploading the files as ASCII with your FTP client (or automatic with FileZilla).

    Thank you very much. I made sure my FTp was uploading in Ascii for text files and it is now working. Thanks again 🙂

    Hi,
    I have the same problem.
    But can you be more accurate Rupan when you say :
    “Upload in ascii for text files” do you mean only .txt files ? or all files?

    I try with Filezilla, automatic mode or ascii mode. Nothing’s changed.
    I try with FireFTP, in automatic mode or ascii mode. Nothing’s changed.
    But FireFTP proposes to choose (on automatic mode) what kind of files for ascii. (.php ? .txt ?…?)
    Thanks.

    Sorry, you can forget my request…I downgrade WP 2.3.1 (don’t work) to WP 2.2.3 : it works with updating permalinks.

    Anonymous

    Hi,

    I also got the exactly same problem when upgrading.

    I fixed it by just copy all wp-***.php files to your root directory

    Example:
    cp wp-* -v /from-new-wordpress/ /your-home/your-www/

    Try it 🙂

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Upgrade error, need help.’ is closed to new replies.