AWPCP - Classifieds Plugin
[resolved] Upgrade Error (5 posts)

  1. reddtessa
    Posted 3 years ago #

    Tried updating through my WP update option get this error:

    Downloading update from http://downloads.wordpress.org/plugin/another-wordpress-classifieds-plugin.zip…

    Unpacking the update…

    Could not copy file. C:/xampp/htdocs/sites/woodbridgemoms.com/wp-content/upgrade/another-wordpress-classifieds-plugin.tmp/another-wordpress-classifieds-plugin/*.php

    Then I tried downloading straight from here rather than upgrading through my WP site... getting this error when unzipping.

    ! C:\Users\Dogg\Downloads\another-wordpress-classifieds-plugin.zip: Cannot create another-wordpress-classifieds-plugin\*.php
    The filename, directory name, or volume label syntax is incorrect.
    ! C:\Users\Dogg\Downloads\another-wordpress-classifieds-plugin.zip: Attempting to correct the invalid file name
    ! C:\Users\Dogg\Downloads\another-wordpress-classifieds-plugin.zip: Renaming another-wordpress-classifieds-plugin\*.php to another-wordpress-classifieds-plugin\_.php


  2. awpcp
    Plugin Author

    Posted 3 years ago #

    Hi reddtessa,

    Let me ask my developer about that strange file name. I see that in the package, I thought it was some new mechanism to use for WordPress. Seems to work OK for UNIX systems, but apparently not so much for Windows.

  3. awpcp
    Plugin Author

    Posted 3 years ago #

    OK, looks like that was a glitch on the upload. Here's how you can fix it manually until the next update:

    - Delete your current install of the plugin
    - Take the one you manually downloaded, open up the ZIP file
    - Remove the *.php file (don't remove ALL files!) at the root of the plugin directory
    - Close the ZIP
    - Install your updated ZIP manually

    That should fix it.

  4. reddtessa
    Posted 3 years ago #

    Thanks, before I tried removing it I went ahead and tried another upgrade through my wp admin and it worked so you ironed it out. :)

  5. awpcp
    Plugin Author

    Posted 3 years ago #

    Glad it's all worked out. I did delete it from the repo to avoid further issues.

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • AWPCP - Classifieds Plugin
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic


No tags yet.