WordPress.org

Support

Support » How-To and Troubleshooting » Upgrade caused loss of Categories

Upgrade caused loss of Categories

  • I just upgraded to ver. 2.3.2, and all my Categories have disappeared. When I go to Manage | Categories, I see this error message:

    Fatal error: Call to undefined function: _get_category_hierarchy() in /home/content/…./FreeBlog/wp-admin/admin-functions.php on line 780

    I assume I’ve missed copying something from the install to my site, or overwrote something I shouldn’t have. Any ideas of what to do next?

Viewing 15 replies - 1 through 15 (of 68 total)
  • I had the same problem yesterday, upgrading from 2.2.2 to 2.3.2. Saw the same error message. I re-installed the files again and double-checked. No categories.

    Others on these board have the same problem. Aparently the database contains the categories, but 2.3.2 is not accessing them. I’ve got questions up in other posts and will bookmark this one, too so I can keep up on any other discussion with you.

    I hope we can get an answer.

    My categories are gone from the category manager, since the upgrade to 2.3.2, and the tags aren’t working either. The tables are still there and in the editor, I can still see the categories. I can still add tags in the editor, but the links just go to a 404 page.

    I have repaired and optimized and fiddled with the permalink structure. Nothing seems to fix this. Is there a patch?

    Has anyone submitted a bug report for this issue or is the team aware of it already?

    My issue has been resolved with an adjustment to the php configuration on the host’s servers. Don’t know what, exactly.

    Would you mind asking? My blog is dead in the water at this moment without categories. TIA

    I’ve seen the problem reported but no one has duplicated that I know of. Are you sure you deactivated all plugins before attempting the upgrade?

    @davidborrink — if you leave a email or contact link, and you have a 2.2.2 backup of your database, I will do the upgrade for you to ‘experience’ the problem.

    I have no plugins. The only thing I’ve added is a template (Networker) and I tried switching to the WP Classic but the issue still exists.

    I should add that I don’t get an error like the OP. I can see the cats in the db but they don’t show in Public or Admin.

    I’ve been attempting to replicate this as well today and can’t. I did do it once, but it was completely due to User Permissions (See here for a 2.1.x Category upgrade experience.) setup as SELECT, INSERT, UPDATE, DELETE

    I’ve gone from a 2.1.2 backup directly to a 2.3.2 on two machines, several times, without a hiccup other than when I purposely messed with Permissions.

    Tried giving the user full permissions and still no cats. Thanks anyhow.

    I just went from my 2.1.2 backup to the whole 2.x line up to 2.3.2 and I couldn’t replicate anything other than Q’d posts not showing up after an update. All my Cats where the same after each upgrade.

    Now, I am removing all files but the wp-config.php and copying over all new files (no overwriting). I don’t have time to try overwriting each one of the installs to see if there is an extra file somewhere that causes the hiccup though… If I have time, I’ll be back later to see if we can replicate it.

    FYI – I put my old files back on the server (v2.3.1) and I have both my categories and blogroll back. Guess I’ll run it this way and attempt a hand edit of the upgrade affected files later.

    Michael,

    I thought it was 2.2.2 but it’s 2.2.1 that I upgraded from.

    I think there’s a possibility that I didn’t have the plugins deactivated. I know that’s “procedure”, too.

    I can’t quite recall my steps to stop the installation, deactivate the plugin, and I may have replaced the overwritten parts with 2.2.1’s originals, did the plugin deactivation, then went back and did the install of 2.3.2. I’m just not 100% sure.

    Is there a file that perhaps needs a tweak to accept the categories that are clearly listed in the current database? I can’t add any categories right now, so I would think that perhaps there’s a “hack” to a certain php file that might allow the categories back, and then 2.3.3 could re-adjust the database on it’s install and work properly with standards files?

    My wife has posted a lot in the last few days and can’t go back to her 2.2.1 database now.

    My email is [moderated] if you want to contact me.

    DavidBorrink sent me his 2.2.1 database and I installed on my local machine and was able to upgrade to 2.3.2 successfully with all categories intact.

    Talked with David, and we forced a database upgrade by setting his db_version value in wp_options back to 5183 and did the wp-admin/upgrade.php step. It worked and all his categories were there.

    Thank you, Michael!
    I was going to write up a comment to explain the procedure in order to help the others on the board here, but you’ve already pointed to the db_version listing.

    People, this can be done by backing up your database in order to perform a little surgery on the active database by accessing phpAdmin on your hosting server. Turn off your plugins in WP in preparation to do a forced upgrade.

    In a separate browser tab or window, go to your hosting’s phpAdmin, locate wp_options in the left column (and if you have wp_categories in the listing, that’s proof you need to do this; that table should be replaced by a few new tables). Choose Browse, locate db_version in the “option_name” column. If you see the value as 6124, you need to edit it using the edit icon to the left. Change the number to match the db_version number from your previous version (see Michael’s link directly above) and save your change.

    Now, go back to the tab/window of your WP site and after the main URL of your blog add “/wp-admin/upgrade.php” and you’ll be presented with an upgrade window. WordPress is saying, “hey, your database is not a 2.3.2 version, we need to upgrade”. WP sees the old number in the database and goes into upgrade mode. Click to upgrade and this should change your categories to the new terms, tags, etc. that 2.3.2 needs to access.

    If successful, then activate your plugins again and breathe a sigh of relief. Your categories are back!

    That’s how we did it.

    Just an interesting point about David’s first, failed, upgrade. The wp_categories table was still in his database, there were no terms tables (normally there would be 3 such tables), and he was able to Write Posts after the upgrade. The bottom of his admin panels showed 2.3.2 as the version, and the ‘db_version’ in his ‘wp_options’ table was 6124 (which is the value from a 2.3.2 upgrade).

Viewing 15 replies - 1 through 15 (of 68 total)
  • The topic ‘Upgrade caused loss of Categories’ is closed to new replies.
Skip to toolbar