WordPress.org

Support

Support » Miscellaneous » upgrade broke things

upgrade broke things

  • Go to http://www.westmouthbay.com to see the error message
    Last night yum upgraded mysql to

    mysql i386 4.1.15-1.FC4.1 updates-released 2.9 M
    mysql-server i386 4.1.15-1.FC4.1 updates-released 6.8 M

    and it broke the database login process. I will admit that I am week on my databasing (newbie).

    Has anyone here had a similar experience?
    I tried google to little avail.

Viewing 7 replies - 1 through 7 (of 7 total)
  • Or maybe they also renamed the database itself. Might want to check with your host (yum?) and make sure your wp-config.php has the correct database information.

    sorry.. i have yum run as a cron job nightly to update my computer’s software…

    the info in /var/www/html/wp-config.php has been unchanged..

    thank!!
    -josh

    See if you can use phpMyAdmin to access your database.

    yup… it is still there.. i check via phpMyAdmin

    Mark (podz)

    @podz

    Support Maven

    “it broke the database login process”
    Can you describe exactly the problems you are seeing ?

    I went to my webpage yesterday morning and saw this:
    http://www.westmouthbay.com
    the

    “Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at westmouthbay.com. This could mean your host’s database server is down.”

    error

    I got curious and discovered that YUM upgraded mysql that night. Everything worked fine previously (since mid summer). I am assuming the upgrade screwed something up. I was hoping someone here may have seen this before. The info is still in the DB and my wp-config file seems to be untouched.

    /var/log/yum.log
    […]
    Nov 30 07:14:29 Updated: mysql.i386 4.1.15-1.FC4.1
    Nov 30 07:15:49 Updated: mysql-server.i386 4.1.15-1.FC4.1
    […]

    the contents of /var/cache/yum/updates-released/packages/
    suggested to me that the previous version of mySql was:
    […]
    mysql-4.1.14-1.FC4.1.i386.rpm
    mysql-server-4.1.14-1.FC4.1.i386.rpm
    […]

    I went to my webpage yesterday morning and saw this:
    http://www.westmouthbay.com
    the

    “Error establishing a database connection

    This either means that the username and password information in your wp-config.php file is incorrect or we can’t contact the database server at westmouthbay.com. This could mean your host’s database server is down.”

    error

    I got curious and discovered that YUM upgraded mysql that night. Everything worked fine previously (since mid summer). I am assuming the upgrade screwed something up. I was hoping someone here may have seen this before. The info is still in the DB and my wp-config file seems to be untouched.

    /var/log/yum.log
    […]
    Nov 30 07:14:29 Updated: mysql.i386 4.1.15-1.FC4.1
    Nov 30 07:15:49 Updated: mysql-server.i386 4.1.15-1.FC4.1
    […]

    the contents of /var/cache/yum/updates-released/packages/
    suggested to me that the previous version of mySql was:
    […]
    mysql-4.1.14-1.FC4.1.i386.rpm
    mysql-server-4.1.14-1.FC4.1.i386.rpm
    […]

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘upgrade broke things’ is closed to new replies.