Support » Installing WordPress » Upgrade brickwall – functions.php

  • I deleted everything from my existing 1.2.2 install that had some 1.5 files mixed in from previous upgrade attempts. I have modified files as per CODEX and podz’ directions.

    I keep getting the following error messages above the admin page. My own theme does not show as an option that can be selected.

    Any tips, ideas, help, would be appreciated.

    Warning: file(/home/anderson/public_html/wpblog/wp-content/themes/sublemon/style.css): failed to open stream: Permission denied in /home/anderson/public_html/wpblog/wp-includes/functions.php on line 1324

    Warning: implode(): Bad arguments. in /home/anderson/public_html/wpblog/wp-includes/functions.php on line 1324

Viewing 8 replies - 1 through 8 (of 8 total)
  • Moderator James Huff


    Volunteer Moderator 🚀

    You wouldn’t be trying to run WordPress v1.2.x with a v1.5 database, would you?

    Since I’ve replaced eveything but the database and wp-config.php with 1.5 files, no, I don’t think there’s any way I could be running a WordPress 1.2.

    BTW, before having this go at it, I did a fresh install of WP 1.5 in a different directory, with its own new database, then did the required modifications. The whole thing went well indeed, and there was 1.5, with my theme.

    I really don’t want to have to change the URL of my blog. I did that when I started with WP in December. I’ve already had to ask a bunch of people to update links (some are difficult to contact and a few treat it as a nuisance).

    I think what macmanx is trying to say is, did you run /wp-admin/upgrade.php to make sure the database has all the required changes for 1.5?

    Yes, I ran the upgrade and got the message indicating that if I can see it, all is well. In fact, with a sort of messed up variation of Kubrick, the posts are there and so are the comments, so the DB is connected and appears to be functioning.

    The problem is that my theme isn’t available as a choice on the admin page so that I can select it. And I get the above noted error messages above the admin page.

    By the way, if it would be of help in sorting out whatever’s wrong here
    my blog can be seen at


    The error you are receiving coresponds to the function have_posts which is a major one (line 1324 of functions.php) and the permission denied seems to indicate that its not talking to the database.

    Is there any way you can delete the database and recreate it and import your entries? If not, do you have access to phpmyadmin so that you can run a repair of the tables to rule out any corruption?

    I eventually gave up on trying to salvage anything from the previous install of 1.2 except the DB. I eliminated everything from the directory again and then surfed my Web space using the cPanelX file manager, with no files being hidden. I located and renamed a Fantastico log file.

    The next install using Fantastico went off like clockwork. I got WP 1.5 to hook to the DB using the upgrade function and almost all was well.

    I very carefully began moving into the new blog, using a theme from among Alex King’s terrific contest entries. How and why I don’t know (maybe the javascript module for Blogrolling?), but the index.php came up short a </div>, which someone at another site was kind enough to point out to me. The effect was to drop the sidebar(s) of different themes down below the bottom line of the last displayed post on the page. Since I got that to rights, WP 1.5 has been really good.

    y advice to others who run into what seem like the ghosts or remnants of previous installs is to be thorough in deleting everything before doing a fresh install into a directory previously used for WP.

    One problem remains, with trackbacks, and I will post a separate query about that.

    BTW, my thanks to all who offered ideas and otherwise tried to help.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upgrade brickwall – functions.php’ is closed to new replies.