WordPress.org

Support

Support » Plugins and Hacks » Upgrade breaks API path

Upgrade breaks API path

  • I [svn] upgraded today following the recent few updates, and as before, the upgrading process broke the API and made /api 404. Thankfully, I have monit checks set up for these, so I was instantly alerted.

    As I reported before, re-saving doesn’t work, but first changing the path value to something random and then back to “api” does the trick.

    Any idea why this keeps happening and how to make it not do that in the future?

    http://wordpress.org/extend/plugins/json-api/

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author dphiffer

    @dphiffer

    Yeah, I’ve had this happen to me before, and I’m still not sure what might be happening. Do you remember what the old version you were running prior to doing the svn update? I’m going to see if I can replicate the problem in my dev environment.

    Plugin Author dphiffer

    @dphiffer

    I’ve tried switching between 1.0.7 and trunk without seeing the problem. Are you able to replicate the bug by downgrading and re-upgrading?

    I was running 1.0.7, I believe.

    I just tried to downgrade back, test, then up, and test. No problems. So not sure what keeps happening that would do this 🙁

    Plugin Author dphiffer

    @dphiffer

    Yeah, I’ve never been able to reproduce this consistently. And it’s hard to debug without a set of repeatable steps. I’ll try to run through some possibilities, though, it’s something that comes up on the wp-hackers list from time to time.

    i have almost the same problem

    on my site i still can access from the URL, but if i try to access via ajax the response returns an error

    Plugin Author dphiffer

    @dphiffer

    Weird, rommelxcastro, could you send me the URL? You can email it to me at dan at phiffer dot org if you’d rather not have it public.

    Plugin Author dphiffer

    @dphiffer

    Oh, I just saw your other thread. I’ll look into this…

    thanks @dphiffer

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Upgrade breaks API path’ is closed to new replies.