Support » Plugin: AMP for WP - Accelerated Mobile Pages » Upgrade – breaking things

  • Resolved frenchomatic

    (@frenchomatic)


    I just tried to upgrade having tried the other day when the AMP project plugin was a major problem. I then downgraded so all worked again.

    I have now tried with the latest plugins together.

    1. I upgraded the AMP for WP plugin
    2. I then upgraded the AMP project plugin (afterwards)
    3. Emptied W3 total cache
    4. Re-saved permalinks
    5. Emptied W3 total cache again to be really sure

    Amp home page is now blank. Tag pages are also blank. Ordinary pages are fine.

    6. I have deactivated W3 total cache in case of a plugin conflict but no change.

    I have tried re-saving AMP for WP plugin admin settings etc but still blank. Looks like I will need to unwind this and install both previous versions. Will then play on a test system to find out why it is doing this.

Viewing 4 replies - 1 through 4 (of 4 total)
  • On a test system:

    1. Upgraded just the AMP for WP plugin – all works normally albeit the problems with things like comment buttons appearing on the home page.
    2. Then upgraded the AMP project plugin – tag pages are not showing although the home page does.

    Errors showing from config debug are

    Notice: Undefined offset: 0 in /home/(redacted)/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 162

    Notice: Trying to get property of non-object in /home/(redacted)/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 162

    Notice: Undefined variable: selected_cats in /home/(redacted)/wp-content/plugins/accelerated-mobile-pages/templates/features.php on line 170

    Plugin Author Ahmed Kaludi

    (@ahmedkaludi)

    frenchomatic

    (@frenchomatic)

    Yes – fixes the problem above – well done – thanks

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.