Support » Alpha/Beta/RC » Upgrade available

  • I am on the nightlies on a test server.

    The footer in the admin panel used to have a link for ‘stay updated’ when updates were available.

    Now, I notice that it is always a link, and when I go to the upgrade page, it always says that an upgrade is available. Even after running an upgrade, it shows upgrade available.

    Surely that isn’t right? I thought there was a nightly update, so it can’t be happening all the time? Or is the upgrade somehow not actually upgrading?

Viewing 15 replies - 1 through 15 (of 26 total)
  • Update is WP 2.9.2. You shoulnd’t update to this.

    Oh, no. Not 2.9.2

    “You are using a development version (3.0-RC2-15136). Cool! Please stay updated.”

    This one. Keeps telling me that there is an upgrade available.

    I use 3.0 RC2 on my media blog and in update page:

    You are installing WordPress version 2.9.2 English.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Unless you’re using the Beta Testers plugin, the ‘update available’ will always kick you to the latest ‘real’ version (i.e. 2.9.2).

    It’s just because you’re not using 2.9.2 and it detects that.

    That is strange.

    I have:

    An updated version of WordPress is available.

    You are using a development version of WordPress. You can update to the latest nightly build automatically or download the nightly build and install it manually:

    You mean it still tried to update to 2.9.2? I have run the update several times, but I don’t seem to have reverted. I’m still running the RC2. But that may explain how it keeps saying update available, if it keeps trying to install, but can’t because 3.0 RC2 is a newer version….

    The url it downloads from is

    Downloading update from http://wordpress.org/nightly-builds/wordpress-latest.zip…

    I also get the exact same thing if I upgrade manually. The upgrade happens, but the alert still says updated version available.

    Its rather pointless if this url is going to serve 2.9.2 IMO – what’s the point of having a development version at all? I don’t think they would do that, though I haven’t actually checked the code of what I download…

    I don’t have the Beta Testers Plugin. I simply installed the development release. I am a newbie. Is that going to be a problem? Should I still install the plugin even though I’m already on the development release? Is that preventing updates?

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Back in the 2.8 days, when you got on the beta, the only way to stay on it was either the Beta Testers Plugin or manual updates.

    Apparently now, in 3.0, I get this:

    An updated version of WordPress is available.

    You are using a development version of WordPress. You can update to the latest nightly build automatically or download the nightly build and install it manually:

    So I guess it SHOULD work, though I recall it has always been a bit tetchy about checking what the latest and greatest was. I think it’s a false positive, or perhaps since the subversion repository is constantly getting updated, it’s just going to be weird like this. I don’t know if it’s checking against the SVN or the build, though.

    Its rather pointless if this url is going to serve 2.9.2 IMO – what’s the point of having a development version at all? I don’t think they would do that, though I haven’t actually checked the code of what I download…

    Not really. Most people never test the dev version so they don’t care. 🙂

    manntis

    (@manntis)

    I keep getting the ‘1’ flag next to updates, nagging me that there’s an update available. However, if I click it I get:

    You have the latest version of WordPress. You do not need to update. However, if you want to re-install version 3.0, you can do so automatically or download the package and re-install manually

    If I have the latest version, why the hell does WP keep the update nag flag up? It’s annoying.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Do you have any plugins that need updating?

    squawkbox

    (@squawkbox)

    I am getting the same nag (see Manntis comment) and no I do not have any plugins requiring updates.

    Any resolutions yet?

    similar issue: upgraded from wpmu 2.9.2 to wp 3.0.1 using multi site and every couple of hours I get told that 3.0.1 is avaiable 🙁

    upgraded twice manually and at least twice automatically still no solution.

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Does WP show that you’re using 3.0.1?

    It’s possible theres an incomplete install, and you may want to try manually.

    in the footer it says: version 3.0.1 but every couple of hours I get notified about version 3.0.1 being now available… ignoring it will get rid of it until a few hours later…

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Did you try a manual re-install?

    delete wp-includes and wp-admin folder, then copy everything from the latest file over the installation? yes, done that. also done the automatic upgrade a few times, checked file permissions, everything is rosy 🙂

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    Lead Plugin Wrangler

    Just checking 🙂 You would be SO surprised to find how many people say ‘I manually upgraded by clicking the upgrade button!’

    What plugins are you running?

Viewing 15 replies - 1 through 15 (of 26 total)
  • The topic ‘Upgrade available’ is closed to new replies.