Support » Fixing WordPress » “Upgrade automatically” generates errors, not functioning

  • Resolved rklau

    (@rklau)


    Have 2.5 installed and working properly at http://www.rklau.com/tins/. Only feature not working is the plugin updater. When plugins are activated, I get the following error when I try and “upgrade automatically” for any plugin:

    ‘Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /xxxx/yyyyyyy/public_html/tins/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /xxxx/yyyyyyy/public_html/tins/wp-admin/includes/class-pclzip.php on line 5489’

    When I deactivate all plugins, I get a different error:

    ‘Unpacking the update

    Could not create directory’

    I’m happy to deactivate all plugins (I’ve read elsewhere this is required for the upgrade to work), but it would appear that I need to change permissions on a directory somewhere. Any ideas?

    –Rick

Viewing 11 replies - 1 through 11 (of 11 total)
  • I’m getting the “Could not create directory” error as well.

    Dion Hulse

    (@dd32)

    Lead Developer

    ‘Fatal error: Cannot redeclare pclziputilpathreduction() (previously declared in /xxxx/yyyyyyy/public_html/tins/wp-content/plugins/wordpress-automatic-upgrade/lib/pclzip.lib.php:5421) in /xxxx/yyyyyyy/public_html/tins/wp-admin/includes/class-pclzip.php on line 5489’

    Once you upgrade to the latest WordPress Automatic Upgrade plugin the upgrade will work without having to disable it. (I think 1.0 fixes it)

    As for the Cannot create directory error, That sounds like a permission error.
    Can you check that the folder wp-content/upgrade/ exists? If not, try creating it and running an update again. Allthough the folder should be autoamtically created, it may not be being created correctly.

    As dd32 hinted at…the “Cannot create directory” error is indeed a permissions error. Make sure your wp-content/plugins and all the sub-folders in the /plugins directory are writable and it should solve that issue.

    Great feedback everyone, thanks!

    I had to create the /wp-content/upgrade directory (it was not present), set permissions to 777, then update the permissions in wp-content/plugins to 777 as well. Finally, I emptied /wp-content/cache – and plugins are now updating successfully.

    Thanks for the help.

    Warning: Invalid argument supplied for foreach() in /home/mayuonli/public_html/blog/wp-includes/classes.php on line 92

    I’m getting this error in home page and in manage posts admin page….!!!
    can’t access single page.. it returns 404 error… 🙁

    Mayu

    my prob solved
    I got da same prob while upgrading to WP 2.5!!!
    Later I come to know from Ravidreams dat it’s a theme related issue.. use Cutline 2.1 by Chris Pearson and David Peralty.
    It’s a solution for this problem!!!

    I’m getting the error:

    Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature

    on one of my sites, but not on any of the others on the same server. What’s the fix?

    I’m getting the error:

    Downloading update from http://downloads.wordpress.org/plugin/all-in-one-seo-pack.zip

    Unpacking the update

    Could not create directory

    The directory upgrade was created with 775 permitions and the directory plugins has the same permition rule.

    What can I do ?

    If this is related to WPAU or WordPress Automatic Upgrade plugin conflicting with the automatic upgrade function of the WP core, you can disable WPAU and try upgrading again:

    http://kramfs.com/2009/02/11/wordpress-automatic-upgrade-fatal-error-cannot-redeclare-pclziputilpathreduction/

    thanks kramfs!

    glad WordPress has built in automatic upgrading now.

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘“Upgrade automatically” generates errors, not functioning’ is closed to new replies.