WordPress.org

Forums

Upgrade and unclickable duplicate category url's (13 posts)

  1. paperlion
    Member
    Posted 10 years ago #

    Upgraded from 1.2.2 to 1.5 and noticed that any category creates an unusable double url, like this:

    http://mydomain.com/wp-fdn3/http://mydomain.com/wp-fdn3/index.php?cat=10

    This site has imported subcategories since 1.2.2 and this might have something to do with it, especially because the categories and subs are sitting in a strange order - the subcats are all in a row toward the top of the menu sidebar area, while the main categories they exist from are not interspersed behind them, but just site at the bottom! Anyone know what's going on here?

    Thanks hugely.

  2. NuclearMoose
    Member
    Posted 10 years ago #

    When you did the upgrade, did you also delete your old rewrite rules and then update them?

  3. paperlion
    Member
    Posted 10 years ago #

    Never used rewrite rules.

  4. paperlion
    Member
    Posted 10 years ago #

    Als0 just realized, that on the Options screen, I can't get the blog-name-if-different window to remain blank.

    Right now the blog is in the same directory as the WordPress address, but the window won't stay blank.

    This may be significant, since if I change the line to just index.php, this file gets added to the first part of the doubled url too, like this:

    http://mydomain.com/wp-fdn3/index.php/http://mydomain.com/wp-fdn3/index.php?cat=10

  5. paperlion
    Member
    Posted 10 years ago #

    Close by no cigar...

    Remembered that when modifying the options table after importing the database, I had put in the full url into the blogname field, since I couldn't recall how it had been just seconds before - figured it couldn't hurt.

    Well, I installed a different default copy of wp on a different folder and database, to see what it should look like - the blogname shows as just the last part of the folder name (fdn4 as the folder is wp-fdn4). Alternatively, the name could be being taken from the database name. Either way, my real installation has a similar naming convention, so I substituted the parallel blogname in that field.

    The problem wasn't corrected, but the duplication does equal the blogname:
    http://mydomain.com/wp-fdn3/fdn3?cat=24

    Can someone reach out and touch this with a magic solution?

  6. paperlion
    Member
    Posted 10 years ago #

    Voila!
    I left the field blank in the blogname field in the options table of the database, and it works.

    Am very suspicious though of what's going on. The default installation does have a value in this field, and it works. If I were to put a value there with this installation's current settings, it wouldn't.

    Does anyone know what other setting might be off? This install WAS working fine with a value in the blogname field and with the default settings before the data was restored to it.

    Thanks.

  7. paperlion
    Member
    Posted 10 years ago #

    This quick fix may be just masking the problem. For instance, trying a few different pretty-standard hacks for hiding categories, and can't get any of them to work.

    Is there something else in the database that would cause this?

    I certainly don't wish this on anybody, but isn't someone familiar with these inner reachings of WPs dark side?

    I really need to solve this so I can get back on with life.

  8. TechGnome
    Moderator
    Posted 10 years ago #

    Did you delete all your files before upgrading? Also did you remember to run the upgrade.php file?

    Simple questions, but things people tend to overlook.

    Tg

  9. paperlion
    Member
    Posted 10 years ago #

    Yes. This was a new install of 1.5. Copied over only the theme files and modified them.
    Didn't run the upgrade first - forgot about it, but then ran it and all the posts and other content seemed fine.

    Data was changed over to UTF-8 with the iconv mySQL utility. Did a decent job, but could there be some sensitive data fields that didn't like it?

    How could I check all the references to the siteaddress field? (The duplication error changes as I change this field's contents (in the options table using phpmyadmin)!

    Much appreciated.

  10. TechGnome
    Moderator
    Posted 10 years ago #

    If it's a new install, there's no need for the upgrade.php.... only if you are comming from an older version.

    Check your cookies & clear them out if you can.

    Once yo uget logged back in, check your setting for permalinks and make sure they are correct. Hit the Update .htaccess file button too, just to be on the safe side.

    Tg

  11. TechGnome
    Moderator
    Posted 10 years ago #

    OOOh.... I jsut saw the rest of yuour post there.... did you run that conversion on all tables in your database? If so, the wp_options table maybe toast. That's where the site url and other info used to create the links is located. May want to have a look at it from phpMyAdmin, or what ever control panel options your host gives you. Hopefully it hasn't been tanked.

    Tg

  12. paperlion
    Member
    Posted 10 years ago #

    Looks okay, but is that total proof?

    Glad you mentioned this.

    First because, I never saw it documented not to convert any particular table - is options the only one?

    Second, is it after being converted that disaster happens (assuming that running the conversion backwards wouldn't work - why wouldn't it?) or only after the wp database takes it out for a drive? (I have the original 8859 version and the utf copy on hand - should I highlight everything except the options table before the encoding changes?)

    Thanks.

  13. HighOctane
    Member
    Posted 9 years ago #

    I have just got done batteling this problem myself. (example ----> http://www.wagnertech.net/blog/go.php?http://www.wagnertech.net/?p=46)
    deleting the BLOG ADDRESS URI in the OPTIONS GENERAL area, only to have it magically return again, after many different attempts, I found by putting a period there, the double url I was getting when clicking on a READ MORE link is now fixed.

    WORD OF WARNING!!!!!!
    After I deleted the WordPress address (URI), I was unable to log in, and my WP blog was all screwed up. so be carefull! and BACKUP BEFORE PLAYING AROUND lol, but we always do that.... don't we.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.