WordPress.org

Support

Support » Installation » [Resolved] upgrade 2.7 to 2.8.4 fatal error

[Resolved] upgrade 2.7 to 2.8.4 fatal error

  • attempting to upgrade from within 2.7 to 2.8.4 gives fatal error message shown below

    Fatal error: Cannot redeclare class pclzip in /home/herbalsf/public_html/itsmytwocents/wordpress/wp-admin/includes/class-pclzip.php on line 171

Viewing 7 replies - 1 through 7 (of 7 total)
  • I did a similar upgrade on Friday… since then a catastrophic set of events happened and my blog is now (i assume) dead and unrecoverable ! 🙁

    whooami

    @whooami

    Member

    having read your other threads, you issue isnt similar to this one.

    2cents,

    disable the automatic upgrade plugin. if you cant get to the plugins page, delete the plugin files off the server using your trusty ftp client.

    and btw, I can probably fix your broke blog.

    I seriously doubt that your blog is unrecoverable. WordPress uses a SQL database to store allof your pages, posts, and other information. You will be able to get your site back up and running if you can access your wp-config.php (located in the root folder of your site) and copy it along with any theme files you want (located in the wp-content/themes folder).

    Once you have these things copied, you can wipe out all the WordPress files for your site and then reinstall the most recent version in it’s place.

    A new site will not be connected to your old database -so your site will look empty -so replace the new site’s wp-config.php with the old one.

    This will connect your new site to your old database. Then go to “http://yoursite.com/wp-admin/upgrade.php”

    This will upgrade your SQL database if necessary.

    whooami

    @whooami

    Member

    CCrest, thats not the solution to jeanlucb’s problem, but you can roll with that, I guess. the problem is inside the db that you just had him connect to (per your directions).

    its a searchable issue, in other words.

    Rodger that.

    I didn’t read any of his other posts. Something screwed up his database then. Sounds like an evil plugin.

    Thanks.

    On my problem — fatal error upgrading 2.7 -> 2.8.4, my site never died, only the update failed instantly. Should I use the CCrest method to upgrade?

    OK , I got rid of the auto-update plugin. Saved a copy of plugins, themes, and wp-config.php. Did a backup.

    Used simpleScripts to update –>
    Use the existing database option.
    Get the database info from wp-config.php
    Specify same admin and password values, same WP site name
    Allow overwrite of existing files
    Let it fly.
    Start WP
    Allow database upgrade
    D O N E

    Takes 5 minutes when you know all the steps
    Thanks for all help.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] upgrade 2.7 to 2.8.4 fatal error’ is closed to new replies.