[resolved] Upgrade 2.1 to 2.1.3 and RSS feeds broken (8 posts)

  1. stephennewton
    Posted 9 years ago #

    I've just upgraded from 2.1 to 2.1.3 using Fantastico. All looked okay until I realised my RSS feeds were broken. I have two feed plugins:
    Angsuman's Feed Copyrighter 1.0 and
    FD Feedburner Plugin 1.1 (main feed only, not comments)
    Both are currently active. Deactivating them makes no difference.
    The main feed can be found at:
    An example comment feed (i.e. one not covered by the FeedBurner plugin) can be found at:
    Help greatly appreciated.

  2. Chris_K
    Posted 9 years ago #

    If I had to guess, I'd suggest that you have a file with an extra blank line either before the opening <?php or after the final closing ?>.

    I'd start by checking the wp-config.php and plugins for it.

  3. stephennewton
    Posted 9 years ago #

    Thanks, but that means nothing to me as I'm not a php programmer. However, I have tried deactivating each plugin in turn to see if that resolves the issue, but no luck.

    I guess I could uninstall WP and reinstall it fresh, do you think that might work?

    With DB_NAME, DB_USER and DB_password blocked out, my wp-config.php looks like this:
    // ** MySQL settings ** //
    define('DB_NAME', '**************'); // The name of the database
    define('DB_USER', '**************'); // Your MySQL username
    define('DB_PASSWORD', '************'); // ...and password
    define('DB_HOST', 'localhost'); // 99% chance you won't need to change this value

    // You can have multiple installations in one database if you give each a unique prefix
    $table_prefix = 'wp_'; // Only numbers, letters, and underscores please!

    // Change this to localize WordPress. A corresponding MO file for the
    // chosen language must be installed to wp-includes/languages.
    // For example, install de.mo to wp-includes/languages and set WPLANG to 'de'
    // to enable German language support.
    define ('WPLANG', '');

    /* That's all, stop editing! Happy blogging. */

    define('ABSPATH', dirname(__FILE__).'/');

  4. Thanks, but that means nothing to me as I'm not a php programmer.

    You don't have to be a php programmer to understand what a
    "blank line" is.

    Open your wp-config.php file in a text editor.
    Look at it.
    Does it have a blank line at the top, before the "<?php" text?
    Does it have a blank line at the bottom, after the "?>" text?

    Remove those blank lines.

  5. stephennewton
    Posted 9 years ago #

    Okay. I've gone through it and a few dis have blank lines at the end, which I've deleted. But no joy. All worked well before moving from 2.1 to 2.1.3. This is a typical error message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/freesexc/public_html/pr-consultant/index.php:1) in /home/freesexc/public_html/pr-consultant/wp/wp-commentsrss2.php on line 8
    http://www.pr-consultant.co.uk/2007/04/brazen-public-relations.html Thu, 26 Apr 2007 14:38:53 +0000 http://wordpress.org/?v=2.1.3

  6. Warning: Cannot modify header information - headers already sent by (output started at /home/freesexc/public_html/pr-consultant/index.php:1)

    See what happens when you don't tell us everything?

    Your blank line is the first line in your index.php file in the pr-consultant directory.

  7. stephennewton
    Posted 9 years ago #

    Should anybody else have the same problem:

    I have discovered the issue was that when I added items to my .htaccess file (e.g. 301 redirects) I left blank lines between blocks of code. This caused no problems for WP prior to 2.1.3, but there you go. (My blog homepage is different to the directory in which I installed WordPress.)

    Thanks to HandySolo and Otto42 for the help.

  8. Blank lines in the .htaccess file are perfectly valid and acceptable. I have several blank lines in my .htaccess files.

    Blank lines (outside of <?php and ?> tags) in index.php or any other core WordPress file are not acceptable. They'll cause output prematurely, which breaks things.

Topic Closed

This topic has been closed to new replies.

About this Topic