Support » Fixing WordPress » Upgrade 1.5 > 1.5.1

  • Mark (podz)


    Support Maven

    Please read the whole thread – many people have added useful information !

    This applies ONLY to an upgrade from 1.5 to 1.5.1 – it is not the method to use if upgrading from an earlier version.

    It may look complicated – it isn’t!

    1. BACKUP your database
    2. Download 1.5.1. Unzip it.
    3. Open the unzipped folder, and DELETE wp-images. (You have no need for these in an upgrade)
    4. Now open your ftp program and go to your blog directories
    5. On the server, delete the directories wp-admin and wp-includes. Note: If you have “languages” directory in your wp-includes folder (with .mo files) you may want to save/backup those before deleting the wp-includes directory. Upload the new ones.
    6. The Classic and Default themes have been changed slightly so if you wish to, you can upload those to your wp-content folder.
    7. (See the post below this)

    8. On the server and at blog root, delete the old WordPress files and upload new ones. I recommend you do this one by one if you are not sure. Do not delete wp-config.php.
    9. Now run “”

    That’s it.
    You don’t go near your wp-content folder so your themes and plugins are perfectly safe. this is a very easy upgrade – probably the easiest one yet for WordPress.

    Please use a proper ftp client.

    Please don’t think it’s easier to overwrite and not bother deleting files first – you will get errors, you’ll post here for help, we’ll tell you to do it properly, you will and the errors will go away. Far easier to cut that middle stuff out 🙂

    If you wish, you can delete the following files:

Viewing 15 replies - 16 through 30 (of 203 total)
  • Well I upgraded and the CSS aint showing:

    Well I did this, now nothing shows up at all ->

    Here’s your problem:
    <link rel=”stylesheet” href=”http://r0& #215;” type=”text/css” media=”screen” />


    Ok podz Or Matt, heres a bug that I got it fixed: I validated my site and viewed the source and found:

    <link rel=”stylesheet” href=”http://r0×” type=”text/css” media=”screen” />
    Well umm, I dont know why it fu**** the r0x0rz word up so instead of using the css bloginfo function thing, I just placed the URL and fixed it. This was fine in 1.5, I used the bloginfo CSS url function and It worked. (Forgot what the function was but it was in href=”<?php bloginfo…”

    Blah, too late. Thanks for the help tho Idbehold.

    Also, For people using BA-stats, Please disable it when upgrading since It does not work with 1.5.1.

    Just upgraded 9 sites which use WP to 1.5.1 and everything is lovely, and somehow the designs are all a little tigher, so much faster…

    : P

    habbit abated for the time being…

    thanks for the update!

    How much of a concern is the security problem? Is it public knowledge, or something the dev team has kept quiet? I don’t want to upgrade right now, but if there’s a large risk for being hacked, I would rather upgrade now that suffer the consequences. It’s just not a good time for me with exams and all.

    Mark (podz)


    Support Maven

    The risk is not yet public knowledge.

    Mark (podz)


    Support Maven

    Jinsan – use your ftp client and look at the DATE column along from each file. That will tell you the last time you altered / uploaded a file which may help. Click on the top of that column to sort by date.

    I got another problem. i created a page and It doesnt seem to work. I get my 404…Any help?

    I have the same problem as cyberhomie. Followed instructions step by step. Even deactivated all plugins, but all I got was a blank page following the upgrade.

    I’ve reverted to 1.5 until someone figures this out. If there’s anything special you’d like me to try to attempt and determine the root of the problem, just shout it out! 🙂

    You cleared cache and hard-refreshed, right?

    Mark (podz)


    Support Maven

    cyberhomie / bwahahax – check your themes directories ?
    Did you upload the new default / classic themes ?

    How can I disable BAStats after I already upgraded, but I can get to any of the pages? Is there a way to manually disable it?

Viewing 15 replies - 16 through 30 (of 203 total)
  • The topic ‘Upgrade 1.5 > 1.5.1’ is closed to new replies.