Support » Plugin: Collapse-O-Matic » Upgrade 1.7.11 not compatible with PHP 7.2 and 7.3?

  • Resolved cosmetiqua

    (@cosmetiqua)


    Hi, I have just gotten the plugin upgrade prompt from my wp page, but it says it is not possible, since it requires a newer version of PHP. My site was running on PHP 7.2 and I have just upgraded it to 7.3. The update of your plugin is still uninstallable and still requires a newer version of PHP although it says it only needs 7.0 or higher in the description. Please, tell me where it all went wrong and what can I do to update collapse-o-matic? Thanks!

    The page I need help with: [log in to see the link]

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Author twinpictures

    (@twinpictures)

    Hello. If the site was running php PHP 7.2 you should have not received this message. As mentioned, the plugin only checks for a minimum of 7.0.
    have you verified which version of php is installed using phpinfo() or any number of plugins?

    Once PHP 7.0 or greater has been verified, try downloading the plugin’s .zip file and manually upgrading by either removing the old plugin and uploading the .zip via the WP plugin admin page–or simply by unpacking the .zip and uploading it’s contents to the plugin folder via FtP.

    Plugin Author twinpictures

    (@twinpictures)

    any update on the issue?

    Thread Starter cosmetiqua

    (@cosmetiqua)

    Hi! Issue solved, you were right, the server was running on 7.2, but the http access file was still referring to 5.6 without me knowing it. Changed it and it all works as it should now. Thank you!

    Plugin Author twinpictures

    (@twinpictures)

    happy to hear you got the issue resolved.

    how did you do that? i have the same problem here 🙁

    Plugin Author twinpictures

    (@twinpictures)

    @ckardesler – you will need to contact your hosting provider and ask for assistance.

    Did you verify that your WordPress is NOT running the desired PHP version?

    exactly.. In my Cpanel I set it up to 7.2 but when I check my site it’s still on 5.6. http access is referring to 5.6 i think. But I don’T know how to fix that.

    Plugin Author twinpictures

    (@twinpictures)

    ok, if you are using Cpanel it should be easy to change the php version. However, your cpanel might be set up to work with multiple versions of PHP–so you will need to also define this at the domain level. Your best bed it to reach out to the support channel of your hosting provider and have them guid you.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Upgrade 1.7.11 not compatible with PHP 7.2 and 7.3?’ is closed to new replies.