[resolved] Upgade: PHP Fatal error: Call to undefined method wpdb::tables() in upgrade.php (9 posts)

  1. schestowitz
    Posted 6 years ago #


    I've struggled for hours trying to upgrade from 2.9.2 to 3.0.1. I have done all that's required (plug-ins disabled, etc.) and no matter what I try, whenever I upgrade the database (about half a gigabyte) through wp-admin/upgrade.php the process immediately hangs with the following error.

    PHP Fatal error: Call to undefined method wpdb::tables() in /home/techright/public_html/wp-admin/includes/upgrade.php on line 1403, referer: http://techrights.org/wp-admin/upgrade.php

    I do not know where to proceed from here. Hours spent researching to no avail. I can get 3.0.1 running at the front end, but I can't get to the admin panel without upgrading the database (which I can't do because of this error).

  2. Are you running a drop in alternative database class?
    (could be a caching plugin also)

    Look for a file called db.php in wp-content.

    If so you need to get an updated version of that which is compatible with WordPress 3.0.1 before upgrading.

  3. jimgroom
    Posted 6 years ago #

    Figure anything out here? I am running a multi-db setup using the SharDB plugin, and I got the same exact error after I copied the WP 3.0 core files, and tried upgrading the database. Was under the impression the dp.php file was working for this plugin, but I maybe missing something. Reverted back to WPMu 2.9.2 for the moment, but any help would be great.


  4. schestowitz
    Posted 6 years ago #

    Peter Westwood,

    I am extremely grateful. That exactly was the problem. For anyone encountering the same issue (I tried to make the headline/title of this thread the description to which Google returns nothing), here is the solution.

    DB Cache (see http://wordpress.org/extend/plugins/db-cache/faq/ ) not only gets registered among the plugins but it also has files in one's /wp-content directory -- files that are not being updated when WordPress 3.0.x is installed, for obvious reasons. So disabling the plugin is not enough (I did try to find solutions around caching before, but didn't imagine that going beyond disabling and clearing of cache would be required).

    Notice that in order to reinstall DB Cache fully, one needs to do the following:

    How do I uninstall DB Cache?

    1. Disable it at Settings->DB Cache page. The plugin will automatically delete all cache files. If something went wrong - delete /wp-content/db.php, /wp-content/db-config.php and /wp-content/tmp folder. While db.php file exists WordPress will use our optimized DB class instead of own.
    2. Deactivate it at plugins page.

    Basically, that's the source of the problem I had. In my searching for a solution I have read in some other sites that other caching plguins caused similar issues, but the solutions to these issues were different.

    Thanks again Peter for an excellent piece of advice!

  5. rzema
    Posted 6 years ago #

    great, works fine!!!!

  6. Abbi.Umar
    Posted 6 years ago #

    I'm using DB-super-cache but it's work for me too. Thanks a lot.

  7. naverepooc
    Posted 5 years ago #

    Way to be, Mr. Westwood! You hath saved my day. Good vibrations your way.

  8. malletfils
    Posted 5 years ago #

    Hi all !

    I have some blogs which weren't updated to WP3, and I'm trying to do it now. I encounter the same problem as schestowitz. So ok, I need to clear and deactivate cache plugin before upgrading.

    But I have already launched the WP upgrade, so I can't access my admin to deactivate the plugin. It keeps asking me to upgrade the DB. So how can I get rid of the cache plugin without having access to my dashboard ? Or how can I get access to my dashboard ?

    Thanks for your help.

  9. Ron Rennick
    MultiSite Guru
    Posted 5 years ago #

    Rename or delete the plugin.

Topic Closed

This topic has been closed to new replies.

About this Topic