WordPress.org

Support

Support » Installation » Updating WordPress 3.1 – Syntax Error

Updating WordPress 3.1 – Syntax Error

  • Parse error: syntax error, unexpected $end, expecting T_VARIABLE or ‘$’ in /home/a6256684/public_html/wp-includes/cache.php on line 431

    How to resolve this? Thanks!

Viewing 5 replies - 1 through 5 (of 5 total)
  • janechenyj,

    Try to re-upload cache.php file manually and access your website again.

    Thanks. Now it’s another error:

    Fatal error: require() [function.require]: Failed opening required ‘/home/a6256684/public_html/wp-includes/pomo/mo.php’ (include_path=’.:/usr/lib/php:/usr/local/lib/php’) in /home/a6256684/public_html/wp-settings.php on line 83

    Thanks in advance for your help!

    Looks like update went wrong. Download wordpress 3.1. Unzip in on your local computer and upload all the files to wordpress directory. Let Filezilla (or any other ftp client) to upload all the files, because even if the file already exist it could be damages like cache.php was.

    I repeat the entire update process again and it works now. Thanks!!

    I just moved from wordpress.com (which was challenging enough!) to wordpress.org. First thing, they say to update to 3.1. For a person who is NOT techy, is this really necessary? I see all kinds of problems with people doing this update, and they seem to be a LOT techier than me!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Updating WordPress 3.1 – Syntax Error’ is closed to new replies.
Skip to toolbar