WordPress.org

Forums

Updating WordPress 3.1 - Syntax Error (6 posts)

  1. janechenyj
    Member
    Posted 5 years ago #

    Parse error: syntax error, unexpected $end, expecting T_VARIABLE or '$' in /home/a6256684/public_html/wp-includes/cache.php on line 431

    How to resolve this? Thanks!

  2. arkgroup
    Member
    Posted 5 years ago #

    janechenyj,

    Try to re-upload cache.php file manually and access your website again.

  3. janechenyj
    Member
    Posted 5 years ago #

    Thanks. Now it's another error:

    Fatal error: require() [function.require]: Failed opening required '/home/a6256684/public_html/wp-includes/pomo/mo.php' (include_path='.:/usr/lib/php:/usr/local/lib/php') in /home/a6256684/public_html/wp-settings.php on line 83

    Thanks in advance for your help!

  4. arkgroup
    Member
    Posted 5 years ago #

    Looks like update went wrong. Download wordpress 3.1. Unzip in on your local computer and upload all the files to wordpress directory. Let Filezilla (or any other ftp client) to upload all the files, because even if the file already exist it could be damages like cache.php was.

  5. janechenyj
    Member
    Posted 5 years ago #

    I repeat the entire update process again and it works now. Thanks!!

  6. sonjamoss
    Member
    Posted 5 years ago #

    I just moved from wordpress.com (which was challenging enough!) to wordpress.org. First thing, they say to update to 3.1. For a person who is NOT techy, is this really necessary? I see all kinds of problems with people doing this update, and they seem to be a LOT techier than me!

Topic Closed

This topic has been closed to new replies.

About this Topic