WordPress.org

Support

Support » Plugins and Hacks » Updating to Google Maps JavaScript API v3

Updating to Google Maps JavaScript API v3

  • gorky5
    Participant

    @gorky5

    Hi Dylan. This morning I got an email from Google telling me to update my maps API key from v2 to v3 before it expires in May 2013.

    I got a new v3 key and set the allowed referrer as *.mydomain.com/* (obviously putting the correct name in)
    I also added the JavaScript mentioned in this link to my site’s header (adding my key and setting the sensor to true, though I also tried false).

    I then added the new API key to my Geo Mashup settings page. I had to choose Google v2 as the map provider, as when I selected v3 in the dropdown there wasn’t a field to add the API key. Is that as it should be?

    With the new key saved, whenever I load a page I get the following popup:

    Google has disabled use of the Maps API for this application. The provided key is not a valid Google API Key, or it is not authorized for the Google Maps Javascript API v2 on this site. If you are the owner of this application, you can learn about obtaining a valid key here: http://code.google.com/apis/maps/documentation/javascript/v2/introduction.html#Obtaining_Key

    Do you know where I might be going wrong? I’m still using the API v2 key for the time being, but obviously the clock is ticking. Any help you can offer would be great.

    http://wordpress.org/extend/plugins/geo-mashup/

Viewing 2 replies - 1 through 2 (of 2 total)
Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Updating to Google Maps JavaScript API v3’ is closed to new replies.