Support » Plugin: WP Google Maps » updating to 7.10.17 gives GDPR warning that can’t be disabled

  • Resolved allan1978


    On updating to version 7.10.17 the plugin displays a GDPR warning at the top of all admin pages even if GDPR is enabled.

    WP Google Maps – Warning – GDPR Compliance Disabled – Action Required

    The only way to get rid of the warning is to click ‘dismiss and accept responsibility’

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having this issue also.

    Me too. Where’s the Privacy Settings tab? Thanks


    Hello Everyone,

    I am having the same problem too..

    Settings/GDPR compliance tab.

    Once everything is setup and you accept responsibility for GDPR the notice in the dashboard, it just persists and their is strange behavior with regards to pressing the PP button next the accept responsibility button as well. it just loop in on itself when you try to click and view it..

    When i finally manage to clear the notice in the dashboard I then checked the location where I placed the shortcode and after clicking the “I accept’ button I have noted that the cookie is set in the browser and yet where the map shortcode is placed it will not dismiss the privacy policy text in place of the map. So again upon return to the dashboard the previously accepted responsibility GDPR notice is back… go figure..

    This seems to be a very flakey version as sometimes the PP for the shortcode is dismissed in the browser and the map shows and then you leave the page then sometimes upon return there it is again and yet the accepted cookie does already exist…

    There is no Jquery problem being issued in inspector either, theme is set, cache cleared for both the hosts (SGOptimiser – SiteGround) and browser so don’t know what to do next except disable the GDPR PP notification for the map shortcode itself as I have already taken a copy of it and placed it in my sites PP.

    What else is strange too, is that it functions ok if I login as administrator and then view the page in another tab but it has problems as a normal not logged in visitor, this would suggest a possible permissions issue.

    Maybe support can throw some light on it as this was a great plugin until the last couple of releases.
    WP 4.9.6.
    Hueman Pro 1.0.28

    Wpgmaps, Codecabin, any help would be much appreciated.. 🙂

    Ps my system INFO

    ### Begin System Info ###

    Site URL:
    Home URL:
    Multisite: No

    — User Browser

    Platform: Apple
    Browser Name: Chrome
    Browser Version: 67.0.3396.99
    User Agent String: Mozilla/5.0 (Macintosh; Intel Ma
    c OS X 10_13_4) AppleWebKit/537.
    36 (KHTML, like Gecko) Chrome/67
    .0.3396.99 Safari/537.36

    — WordPress Configuration

    Version: 4.9.6
    Permalink Structure: /%postname%/
    Active Theme: hueman-pro-child 1.0 (child theme)
    Parent Theme: Hueman Pro 1.0.28
    Show On Front: page
    Page On Front: Welcome (#5)
    Page For Posts: Unset
    Remote Post: wp_remote_post() works
    Table Prefix: Length: 5 Status: Acceptable
    WP_DEBUG: Disabled
    Memory Limit: 768M

    — WordPress Active Plugins

    AAM User Activity Helper: 1.0
    Admin Branding: 1.1.2
    Advanced Access Manager: 5.3.3
    AWSM Team: 1.1.3
    Carousel Horizontal Posts Content Slider: 3.2.6
    Cookie Notice: 1.2.44
    Currency Converter Widget: 1.0.1
    Disable XML-RPC: 1.0.1
    Email Subscribers & Newsletters: 3.5.1
    Email Subscribers – Group Selector: 1.5.0
    Formidable Forms: 3.02.02
    Formidable Forms Pro: 3.02.02
    Formidable PayPal Standard: 3.08
    Formidable Registration: 2.01.01
    GDPR Data Request Form: 1.2
    Gmedia Gallery: 1.12.11
    GTranslate: 2.8.41
    If Menu – Visibility control for menu items: 0.10
    List category posts: 0.77
    Postie: 1.9.23
    Random Text: 0.3.0
    Really Simple SSL: 3.0.2
    Regenerate Thumbnails: 3.0.2
    SG Optimizer: 4.0.7
    Simple Calendar: 3.1.17
    TinyMCE Advanced: 4.7.11
    WordPress Book List: 5.8.1
    WPBookList Bulk Upload Extension: 1.1.0
    WPBookList Carousel Extension: 1.0.0
    WPBookList Mobile Extension: 1
    WP Easy Paypal Payment Accept: v4.9.5
    WP Google Maps: 7.10.17

    — Webserver Configuration

    PHP Version: 7.0.30
    MySQL Version: 50532
    Webserver Info: Apache

    — PHP Configuration

    Safe Mode: No
    Memory Limit: 768M
    Upload Max Size: 128M
    Post Max Size: 128M
    Upload Max Filesize: 128M
    Time Limit: 120
    Max Input Vars: 3000
    Display Errors: On (1)

    ### End System Info ###

    Hi @perryrylance

    I have updated to the latest version (7.10.18) and retried clicking the “I agree” button for the pre consent before loading the map (where I have placed the shortcode) and it sets the consent cookie but does not show the map and the PP text just persists..

    You can take a look at the site page to see what I mean as I will leave it set for consent but I can’t leave it set like that for long.

    I have tried several browsers and they all have the same problem.. URL below.

    my system info is as above post..

    After latest update I have:
    Deactivated plugin.
    Flushed Host SG cache static / dynamic / memcache
    Reactivated plugin.
    I have cleared browser cache in full.
    After clicking the “I Agree” button Still the consent PP text persists
    However the consent Cookie is listed in chrome successfully.
    No map shown….

    Any input would be most appreciated.


    Hi Andrew

    Sorry to hear this, I visited your site and I can see the problem there.

    I’d recommend you roll back to 7.10.17 if the site is live or this is otherwise urgent.

    If you are confident with PHP, you could try going to /wp-google-maps/includes/class.gdpr-compliance.php and on line 159 you’ll see where the check for the consent cookie is made. If this value evaluates to anything but false / null or an empty string, then the cookie is considered set and the function should return on the following line.

    As you can see, it’s really quite a simple mechanism of setting the cookie in JS, which should simply set it in the $_COOKIES array for PHP on this line.

    If you are not confident looking into that yourself, or would prefer us to, we would need you to open a ticket at and supply your FTP details in order to further investigate.

    Please indicate the message is FAO Perry if you do so.

    I hope that helps?

    Kind regards
    – Perry

    Plugin Author NickDuncan


    Hi @andrewmperryman , @bernadettetp, @allan1978
    Has your issue been resolved – may I close this ticket?

    Hi @nickduncan,

    Looks all good for me.

    Many thanks,

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘updating to 7.10.17 gives GDPR warning that can’t be disabled’ is closed to new replies.