Support » Plugin: Paid Memberships Pro » Updating to 4.6.1 broke the plugin (1.8.10.4) on my site

  • Resolved madphill

    (@madphill)



    Since updating (which was automatic on WP behalf) the plugin menus are still there but they are rendering a warning & fatal error: on the require_once(): method.

    No such file or directory and failed opening required on the membershiplevels.php file line 215

    Help?

Viewing 4 replies - 1 through 4 (of 4 total)
  • Update: upon logging into my FTP and looking at the file the method is calling: admin_header.php has been renamed to admin_header.php.suspected

    I havent seen this before but on doing a google search many say at some point in the life of your site – it has been the victim of a hack and the files were not fully cleaned afterwards.

    So you should research this and clean out the infection..
    Or put a backup you have from before you noticed this happen, back on to remove this problem.

    You can scan it with securi as well.

    You can try to rename the file admin_header.php.suspected back to admin_header.php and see if this helps

    This is resolved and you were correct. This filename had been modified by a malicious source.

    • This reply was modified 2 years, 1 month ago by  madphill.
    Plugin Author Jason Coleman

    (@strangerstudios)

    Glad you figured this out. It seems like your site got malware and then a security scanner renamed the file as part of the clean up.

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Updating to 4.6.1 broke the plugin (1.8.10.4) on my site’ is closed to new replies.