Support » Networking WordPress » Updating to 3.7 archived all of my multisite installations

  • Resolved Rob Roy

    (@danetidwell)



    Not sure what happened. I ran the update, all of my sites disappeared from the menu (including the primary). Went to the Sites page and all of my sites were archived (including the primary site).

    I unarchived all of them except the primary, which isn’t an option.

Viewing 15 replies - 1 through 15 (of 19 total)
  • Rob Roy

    (@danetidwell)

    And even though I unarchived them, they’re all now broken.

    Thanks WordPress.

    Dion Hulse

    (@dd32)

    Core Developer

    This sounds like a failure of http://core.trac.wordpress.org/ticket/12832 / http://core.trac.wordpress.org/changeset/25448

    Can you check what the datatype of archived is in your blogs table?

    If it’s an enum or varchar you can probably get it back and working by following the same upgrade procedure as that ticket has tried to do

    Rob Roy

    (@danetidwell)

    I’m not sure where to find that information. I’m using RazorSQL on an Amazon RDS. I found in wp_blogs:

    1 1 engn.us / 2012-10-29 17:14:07 2013-04-13 00:32:23 1 1 0 0 0 0
    2 2 chicagophoenix.com / 2012-10-29 12:43:27 2013-10-26 21:05:49 1 1 0 0 0 0
    3 3 merewell.com / 2012-10-29 12:43:43 2013-10-17 17:01:04 1 1 0 0 0 0

    Rob Roy

    (@danetidwell)

    It looks like they are tinyint

    Rob Roy

    (@danetidwell)

    Ok, I fixed it. Not sure why the upgrade archived all of the blogs, but I was going through and switched them to 0. Cleared the cache and it all seems to be working correctly.

    Hi, I have a problem with a multi network, multi site installation upgrading to WP 3.7 too.

    All but one of my sites disappears

    I have read through the ‘tickets’ linked to in this support post but I don’t understand what I need to do.

    Can anyone enlighten me? 🙂

    Rob Roy

    (@danetidwell)

    What’s your url and do you have access (and the ability) to the database?

    Robert

    (@robertgrinde)

    I have the exact same issue on my install, all blogs had been set to archived.

    I had to run
    UPDATEwp_blogsSETarchived=0

    on my database, seems to be working now, but I am a bit afraid to run the
    wp-admin/network/upgrade.php script…

    Same here. All blogs archived.

    When will that be fixed? I habe to upgrade 3 more blogs.

    Sorry for the late reply.

    I have a multi-network, multi-site WP installation. 4 different domains in the network and (at the moment) 1 site in each domain in the network.

    All but one of the sites gets archived when I run the 3.7 upgrade.

    The sites that get archived return a message saying something like this site/blog has been archived or can not be accessed when I enter the sites URL in my browser.

    I restored my WP install and the DB using a backup and its back to normal but I don’t want to re-run the 3.7 upgrade until I know what’s wrong and how to fix it.

    Anyone have any suggestions?

    Hi Glen, I’m using Networks+ and having same problems, what are you using as multinetwork sollution?

    Hi nmvdvjr,
    I use http://wordpress.org/plugins/networks-for-wordpress/ since many year and I am very happy with it.

    Hi nmvdvjr,

    I am using MP Multi-Network. Thanks for the link I will take a look at that now

    Hi gmmedia,

    Thanks also for the info about networks-for-wordpress I will read up on that plug in as well. Do you have a multi network, multisite installation? and have you upgraded to 3.7x?

    I don’t mind too much trying different options Just want an easy way to test things out before I upgrade my main web sites.

    Does anyone know if there is an easy way of copying your WP installation and trying out the upgrades first?

    Yes I have 5 multi-network installations.
    For now I have only upgraded one to WP 3.7. For the others I want to wait for a fix.

    First i thought it is a networks-for-wordpress bug, but the developer of the plugin showed me that thread here. Now I know that it is a WordPress bug.

    You can fix the bug with a simple mysql query, but I still want to want for the fix.

    Maybe a dev can tell us, when we can download a fixed WP version.

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Updating to 3.7 archived all of my multisite installations’ is closed to new replies.