[resolved] Updating to 3.4 breaks site with WordPress in its own directory (3 posts)

  1. josephwright
    Posted 4 years ago #

    Hello all,

    I have half a dozen sites that I run, all small scale. Moving to the new v3.4 release has gone smoothly so far with all but one site. It has the WordPress main directory not in the web root but in ~/wordpress/. Trying to access that site at all gives me the error

    Fatal error: Call to undefined function wp() in /home/emlweb/public_html/wordpress/wp-blog-header.php on line 14

    (The other sites all have WordPress installed in ~.)

    The problematic site is running PHP 5.2.9, MySQL 5.0.95-community, Apache 2.0.63. Before I start from scratch and restore from backups, any ideas on what is wrong and what to do?

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Try re-uploading all files & folders - except the wp-content folder - from a fresh download of WordPress.

    FWIW, all of the sites on my local dev server are in sub-folders and I've not come across any updating issues with them.

  3. josephwright
    Posted 4 years ago #

    Great: that worked. (I'd already tried copying just the 'defective' file without success.)

Topic Closed

This topic has been closed to new replies.

About this Topic