Support » Installing WordPress » Updating to 3.4 beta 2

  • Resolved Shapeshifter 3

    (@shapeshifter-3)


    I made a bad error. I got sidetracked while trying to update to 3.4 beta 2 and FORGOT TO DISABLE 40+ Plugins. I downloaded the beta version to my computer; extracted the files; uploaded wp-admin, wp-content, and wp-includes to my server; uploaded all loose files to the server; made sure I didn’t delete any of my content files; and deleted the non-default Theme I was using (I kept the Child Theme).

    When I try to render my websites Admin Panel, here’s the message I get:
    Fatal error: Class ‘WP_Theme’ not found in /home/content/xx/xxxxxxx/html/wp-includes/theme.php on line 107.

    When I try to render my website as a viewer, here’s the message I get:
    Fatal error: Call to undefined function get_front_page_template() in /home/content/xx/xxxxxxx/html/wp-includes/template-loader.php on line 26.

    Here’s my website: Toolbox-4-Websites . Does anybody have any ideas how I can fix this?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Do you have a recent backup?

    RichardWPG,

    Yes I did. Thank you for your reply. I restored my site to WordPress 3.3.1 yesterday by using a backed up database on my host’s server.

    I’m going to make sure I’m more careful next time. I learned a lesson: don’t do something like that when I’m tired, and unfocused.

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘Updating to 3.4 beta 2’ is closed to new replies.