Support » Plugins and Hacks » [Resolved] Updating to 3.0 breaks site

[Resolved] Updating to 3.0 breaks site

Viewing 15 replies - 16 through 30 (of 34 total)
  • Plugin Author Jeff Sterup


    You can download the old version from here http://wordpress.org/plugins/plugin-organizer/developers/.

    Plugin Author Jeff Sterup


    Did you get an error message in your logs?

    Do you mean in error_log in the wp root folder? No, doesn’t look like it

    So you can get it to work without the Selective Plugin Loading turned on? Can you go to the settings page and tell me if there is a message in red text at the top of the page? Or at the top of any of the meta boxes?

    @jeff: There’s no error message at the top of the settings page and I’m running a single install, no multisite.

    Jeff, I installed the old version 2.6.3 again and that still works fine, including selective plugin loading. Strange thing is that the url admin (all arbitrary urls) are gone from the install now, while they were visible in the settings screen of the new version (couldn’t edit or delete them in the new version, but they were visible though) even after manually deleting the new plugin completely and installing again.

    Don’t know if this will help you in any way, hope so though! 😉

    Plugin Author Jeff Sterup


    All of the data moved into the post meta table. So the tables from the old version no longer exist.

    I’ve currently reinstalled v2.6.3, thanks for link.

    When I again try to update to 3.0, through the WP admin panel, I first get the screen that says update successful (something like that), but with my very next click to go anywhere else in admin, I get blank white screen again, and can do nothing else…

    After deactivating all plug-ins except Plugin Organizer v2.6.3, I was then able to successfully update, through the WP admin, to Plugin Organizer v3.0, and then successfully reactivate all other plug-ins without issue.

    I did have some URLs entered in the previous version; did this update account for them?

    Plugin Author Jeff Sterup


    It should have moved all of those to the new custom post type plugin filters. Now that you have that working I have just released a new version. Lol. There was an issue with fuzzy url matching in version 3.0. Version 3.0.1 fixes it.

    OK, thanks. I updated to 3.0.1, and had the same experience of blank screen afterwards, unable to do anything. I happened to have site admin also open on another machine, which, after I returned to it, functioned normally and reflected the 3.0.1 update, just fyi…

    Just fyi, same blank screen issue after 3.0.4 update (the 2 previous updates installed without issue). Deactivating all plug-ins allowed a successful install of 3.0.4 and a reactivation of all plug-ins.

    I just upgraded and got the same error:

    Fatal error: Call to a member function get_page_permastruct() on a non-object in /home/xxxxxx/xxxxxx.com/wp-includes/link-template.php on line 271

    I’ve had the same issue, just updated Plugin Organizer on three of my blogs (3.5.1 and 3.5.2), all resulted in the following error:

    Fatal error: Call to a member function get_page_permastruct() on a non-object in /home/gladbags/public_html/photomagnify.com/wp-includes/link-template.php on line 271

    Was able to resolve by deleting the plugins from each site using Filezilla and re-installing from the WordPress plugin directory.

    Good luck getting it sorted, hope it’s an easy fix!

    Update: It seems my problem was not resolved quite so easily.

    All three sites then proceeded to crash despite having their plugin files and MU php files removed.

    I tried to upload the latest plugin files again via ftp to see if it would allow deactivation but the sites still crashed.

    I then deleted those files but accidentally left the empty ‘plugin organizer’ directory in my plugins folder.

    The site then loaded fine (!). I deleted that empty directory and everything seems okay. I also repeated the process with the other two sites using an empty ‘plugin organizer’ directory and they too now work fine.

    I’m not sure I understand why this works? Does WordPress automatically deactivate a plugin with no files in its directory?

    Anyway I’m back up and running. I hope this is useful to someone in the same position rather than just confusing. Perhaps it will be both!

    Still not working after update 3.0.4.

    Fatal error: Call to a member function get() on a non-object in [path]/wp-includes/query.php on line 27

    Also the add plugin filter menu doesn’t display anything.

    We will stick with the old version for a while..

Viewing 15 replies - 16 through 30 (of 34 total)
  • The topic ‘[Resolved] Updating to 3.0 breaks site’ is closed to new replies.