WordPress.org

Support

Support » Plugins and Hacks » Plugin Organizer » [Resolved] Updating to 3.0 breaks site

[Resolved] Updating to 3.0 breaks site

Viewing 15 replies - 1 through 15 (of 34 total)
  • Plugin Author Jeff Sterup

    @foomagoo

    I’m not seeing any issues on any of the sites I’ve tested it on. Can you manually remove the MU plugin and try to reactivate it? I have not tested it above 3.5.1 so it may be a version problem but without an error I have no idea what the cause is.

    Hi,

    I got the same problem:
    After updating the site went down and shows this error on every page:

    Fatal error: Call to a member function get() on a non-object in [path]wp-includes/query.php on line 27

    Replacing this piece of code on line 27 of query.php:
    return $wp_query->get($var);
    with

    if(!is_null($wp_query)){
        return $wp_query->get($var);
    }

    solves the problem, but it’s not a neath way to do it.

    Deactivating Plugin Organizer makes the error disappear, so it’s definitely PO causing this error.

    @jeff: Can you fix this? Please keep me posted. I will have to go back to the previous version else.

    I am using WP 3.5.2 btw.

    Thanks.

    Oh, and I put a fresh copy of PLuginOrganizerMU.class.php to my wp-content/mu-plugins foldern but that’s no solution either.

    This is the error I get:

    Fatal error: Call to a member function get_page_permastruct() on a non-object in [path]/link-template.php on line 271

    Instead of updating the plugin, I uninstalled it then did a fresh download of ver 3 and its working now.

    Plugin Author Jeff Sterup

    @foomagoo

    So Quest you just did a fresh install of the files right? Not the database settings? It seems like it is having an issue removing the old files or something.

    Sorry, but that’s not working for me.
    I deactivated and deleted the plugin from within wp. Checked if it was completely deleted via ftp and also deleted the pluginorganizerMU.class.php from the mu-plugins folder. THen I uploaded version 3. Even before ectivating I got the same error message on the website:

    Fatal error: Call to a member function get_page_permastruct() on a non-object in [path]/link-template.php on line 271

    I had to activate and deactivate the plugin again to get rid of the error message.

    @jeff – yup, did a fresh install. Don’t even know where the database files are. Technically, this is what I did:

    1. Reverted back to old version
    2. Uninstalled old version in WP
    3. Downloaded ver 3
    4. Activated ver 3

    I re-installed also the way @quest did. Thought I got it working afterwards, but it appears that Selective Plugin Loading is disabled by default then. Since it’s the main function of this plugin, I enabled it and the site went down again, showing the same error message as I posted twice above!

    Warning: Invalid argument supplied for foreach() in /home/mainfile/public_html/wp-includes/query.php on line 1702

    Warning: Invalid argument supplied for foreach() in /home/mainfile/public_html/wp-includes/query.php on line 1702

    Warning: Cannot modify header information – headers already sent by (output started at /home/mainfile/public_html/wp-includes/query.php:1702) in /home/mainfile/public_html/macoris/plugins/wp-splitscreen/core.php on line 13

    Warning: session_start() [function.session-start]: Cannot send session cache limiter – headers already sent (output started at /home/mainfile/public_html/wp-includes/query.php:1702) in /home/mainfile/public_html/macoris/themes/Responsive/library/functions/widgets/google_map.php on line 2

    Jeff,

    Can you tell me how to fix this or maybe how to download the old 2.6.3 as I can’t find it anywhwere. I would rather use the working copy and just reconfigure the plugin again as it has messed my whole site up. I am running the 3.5.2 WP version.

    Edit: I had this in the beggining: Fatal error: Call to a member function get_page_permastruct() on a non-object in [path]/link-template.php on line 271

    Then I deleted the line and saved it, then pasted back line 271 and it reset itself.

    Thank you for any input. I truly appreciate this plugin and the time you have put into it.

    Plugin Author Jeff Sterup

    @foomagoo

    Delete the entire plugin. Including the PluginOrganizerMU.class.php file in the mu-plugins folder. Then access your admin to make sure it is working again. Then either go download the plugin and ftp it to your site or use the admin to get a fresh copy from wordpress.org. Then reactivate the plugin.

    Plugin Author Jeff Sterup

    @foomagoo

    emielm,
    So you can get it to work without the Selective Plugin Loading turned on? Can you go to the settings page and tell me if there is a message in red text at the top of the page? Or at the top of any of the meta boxes?

    Jeff,

    This > “Delete the entire plugin. Including the PluginOrganizerMU.class.php file in the mu-plugins folder. Then access your admin to make sure it is working again. Then either go download the plugin and ftp it to your site or use the admin to get a fresh copy from wordpress.org. Then reactivate the plugin. ” has been done 4 times now.

    It still breaks the website. Where can I get a download from your previous version? Thank you..

    After activating the 3.0 version of the plug-in, I just get a blank screen, cannot do anything.

    I upgraded to WP 3.5.2 this morning before trying to upgrade Plug-in Organizer. I’ve tried all the ideas here and other thread several times, no luck yet.

    Plugin Author Jeff Sterup

    @foomagoo

    emielm,
    I’ve changed a lot about how the backend works. I’m using get_posts now instead of all custom queries. I’m wondering if that is why you are getting the get_page_permastruct() error. I have tested it on 3.5.1 and 3.5.2 both without an issue. Are you running multisite?

Viewing 15 replies - 1 through 15 (of 34 total)
  • The topic ‘[Resolved] Updating to 3.0 breaks site’ is closed to new replies.
Skip to toolbar