Support » Fixing WordPress » Updating themes fails after 5.2 installed

  • Resolved lovingboth

    (@lovingboth)


    Happened on two sites so far and I am reluctant to try it with any more until it works with them. Both were automatically updated to 5.2 (wp-config.php has “define(‘WP_AUTO_UPDATE_CORE’, true);” set). They are on separate servers, both running Debian Stretch with PHP 7.0.33.

    Admin panel seems to be OK, but when I attempt to update the themes (including Twenty Seventeen as well as Twenty Nineteen, plus one other; Twenty Seventeen is active on one site, and a child of Twenty Eleven on the other) the process starts:

    Update Themes

    The update process is starting. This process may take a while on some hosts, so please be patient.

    Enabling Maintenance mode…
    Updating Theme Twenty Seventeen (1/3)

    (it takes a surprisingly long time for the lines after ‘Update Themes’ to appear – this is normally much quicker) but does not get any further. Attempting to go back to the Dashboard fails with a ‘planned maintenance mode’ error, even after several minutes.

    Eventually – I restarted Apache on one server – I can get back to the Dashboard where there is a

    An automated WordPress update has failed to complete – please attempt the update again now.

    message. If I try, the whole process repeats.

    Looking at /wp-admin/site-health.php suggests that the GD module is not installed, however if I attempt to install it on the server, I am told that it already is:

    # apt-get install php7.0-gd
    Reading package lists… Done
    Building dependency tree
    Reading state information… Done
    php7.0-gd is already the newest version (7.0.33-0+deb9u3).
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    It does suggest an update to PHP for security reasons, but that request should be addressed to Debian πŸ™‚

    Same happens with all plugins disabled, and until this point, theme updates (and plugin updates) have not been a problem.

    The page I need help with: [log in to see the link]

Viewing 11 replies - 1 through 11 (of 11 total)
  • Moderator t-p

    (@t-p)

    After updating my test site to WP5.2, I was Auto updated themes without any issue.

    Hence, your issue seems to be site-specific.

    lovingboth

    (@lovingboth)

    Two sites, on two separate servers.

    What versions of what software is your server running?

    I note that 5.2’s site health feature cannot accurately and reliably detect the PHP gd module, so it would not amaze me if there is some other aspect of server settings that it can’t cope with.

    lovingboth

    (@lovingboth)

    What’s in the webserver’s error log is variations of this:

    [Wed May 08 14:55:36.159261 2019] [proxy_fcgi:error] [pid 27002:tid 2923363136] [client 1.2.3.4:54280] AH01071: Got error ‘PHP message: PHP Fatal error: Maximum execution time of 30 seconds exceeded in /home/user/public_html/example/wp-includes/sodium_compat/src/Core32/Int64.php on line 274\n’, referer: https://example.com/wp-admin/update-core.php?action=do-theme-upgrade

    lovingboth

    (@lovingboth)

    .. which appears to be the end of code to multiply a 64-bit integer.

    It does beg the question of why anything in a theme update needs to do that.

    Moderator t-p

    (@t-p)

    lovingboth

    (@lovingboth)

    1. Happens when all plugins deactivated.

    2. One of them has Twenty Seventeen active, the other doesn’t. Both fail. In my experience, changing to Twenty Nineteen would lose the work on setting up Twenty Seventeen to look ok.

    3. Already set to 128MB. If that’s too small, you’re going to break an enormous number of sites.

    4. I can try increasing the maximum execution time in php.ini file, but that will affect something else. And if it won’t complete in 30 seconds, something is broken at the code end.

    lovingboth

    (@lovingboth)

    Increasing it to 60 seconds works, but this is not an acceptable solution.

    There are numerous people who cannot do this because they are not allowed access to the necessary configuration options and it’s not exactly a slow CPU it is running on here.

    lscpu tells me the VPS has a Intel(R) Xeon(R) CPU E5-2630L v2 @ 2.40GHz, and a BogoMIPS of 4800. In comparison, this PC has a 3.4GHz Ryzen CPU and BogoMIPS of 6800.

    It’s not a lack of CPU power that’s the issue.

    lovingboth

    (@lovingboth)

    On the other server – also a VPS, CPU has a BogoMIPS of 4000 – 60 seconds is not long enough.

    If I try to update Twenty Ten on that one, it takes 30 seconds from the appearance of ‘Update Themes’ to the ‘The update process is starting…’ section.

    In this area, the big change in 5.2 was the addition of the sodium_compat library and that gets called on updates now (to have them signed, presumably).

    Curiously when this happens, nothing on the server seems especially stressed. The Curve25519 cryptographic function that’s probably calling the 64-bit multiply is designed to have a constant execution time for any particular thing it’s asked to do, and it looks like it’s too long for this task.

    arrappathor

    (@arrappathor)

    Hello,

    I can confirm the same issue:
    Upgrading to wp 5.2 worked as well as for the translations, but upgrading the standard-themes 2017, 2019 failed.
    Installing new themes is possible via uploading a zip-file, but not via download from wordpress.org.
    Plugins CAN be installed via download from wordpress.org.

    My system is a Raspberry Pi2 with Raspbian stretch, apache 2.4.25 with PHP 7.0.33 and MariaDB 10.1.38; my server is running some other services (single-user friendica-instance, nextcloud-server) without any problems.
    Wordpress-Health-check shows as problems: inactive plugins, the php-version and (manually) deactivated background-updates for wordpress.
    I also have the same /var/log/apache2/error.log-message as @lovingboth

    I worked around the issue by uploading the standard-themes via zip-file.

    Maybe this helps?
    Thank for your efforts in WordPress!

    Moderator Marius L. J.

    (@clorith)

    Hiya,

    Thank you all for your help with providing details here.

    A ticket has been created at https://core.trac.wordpress.org/ticket/47186 which covers the problem described here, and we’ll be posting any updates on the matter there.

    I’m marking this thread as Resolved, so that we know it’s been tackled and a ticket exists (it helps us keep track of which topics still need attention on the forums specifically πŸ™‚ )

    lovingboth

    (@lovingboth)

    I do love the use of ‘A ticket has been created’ rather than, for example, ‘You have already created a ticket’ πŸ™‚

Viewing 11 replies - 1 through 11 (of 11 total)
  • The topic ‘Updating themes fails after 5.2 installed’ is closed to new replies.