Support » Plugin: Easy Watermark » Updating the new version 1.0.0 Crashed my site

  • Resolved rrisler

    (@rrisler)


    Half an hour ago when I tried to update the plugin to the new version 1.0.0 my site broke showing the “white window of death”.
    I solved it as follows:
    1) I renamed the plugin folder by ftp
    2) I reloaded the page and when the folder did not exist the plugin gave an error and was deactivated
    3) I renamed the plugin folder to the original name
    4) I reloaded the plugins page (I was already deactivated) and made a Rollback to the previous version 0.7.2
    The site and the plugin were working perfectly as before.
    I open this to help solve the problem for those that arise and give developers a warning that the version contains errors.

    ESPAÑOL
    Hace media hora cuando intenté actualizar el plugin a la nueva versión 1.0.0 mi sitio se rompió mostrando la ventana “blanca de la muerte”.
    Lo solucioné de la siguiente manera:
    1) Renombré la carpeta del plugin por ftp
    2) Recargué la página y al no existir la carpeta el plugin dió error y se desactivó
    3) Volví a nombrar la carpeta del plugin al nombre original
    4) recargué la página de plugins (ya me figuraba desactivado) e hice un Rollback a la versión anterior 0.7.2
    El sitio y el plugin quedaron funcionando perfectamente como antes.
    Abro esto para ayudar a solucionar el problema a los que les surja y dar un aviso a los desarrolladores de que la versión contiene errores.

    SERVER DATA
    WordPress 5.2.3
    PHP 7.2 (ea-php72)
    MySQL 10.2.18-MariaDB
    wp-config.php WP_MEMORY_LIMIT 512M

    The page I need help with: [log in to see the link]

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Kuba Mikita

    (@kubitomakita)

    Hi, sorry it crashed your website. Could you please paste the error it gave you?

    Hi!
    I confirm that the site has become unavailable after the update. PHP error output is disabled for the site. WordPress finished updating the plugin with a message about the need to contact the administrator.

    WP 5.2.3
    PHP 7.3.8 x64

    Plugin Author Kuba Mikita

    (@kubitomakita)

    You should get the detailed error in the email

    @kubitomakita, the site’s message said this. But there was no letter.
    Moreover, it was not possible to repeat the error on the local site. The plugin was updated without errors. The difference between online sites and local sites is to disable error output and enable caching for an online site.

    Plugin Author Kuba Mikita

    (@kubitomakita)

    Quite weird. But without the error we won’t be able to help 🙁

    It should be saved on the server as well in the logs.

    @kubitomakita, repeat on online site with debug on

    • This reply was modified 2 years, 8 months ago by vralle.
    • This reply was modified 2 years, 8 months ago by vralle.
    • This reply was modified 2 years, 8 months ago by vralle.
    • This reply was modified 2 years, 8 months ago by vralle.

    @kubitomakita, I repeated the error.

    PHP Notice: Trying to get property ‘feeds’ of non-object in ../wp-includes/post.php on line 4153
    PHP Notice: Trying to get property ‘use_trailing_slashes’ of non-object in ../wp-includes/link-template.php on line 49
    PHP Fatal error: Uncaught Error: Call to a member function get_author_permastruct() on null in ../wp-includes/author-template.php:346
    Stack trace:
    #0 ../plugins/wp-super-cache/wp-cache-phase2.php(2820): get_author_posts_url(‘1’)
    #1 ../plugins/wp-super-cache/wp-cache-phase2.php(2916): wpsc_delete_post_archives(Object(WP_Post))
    #2 ../wp-includes/class-wp-hook.php(288): wp_cache_post_edit(649)
    #3 ../wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array)
    #4 ../wp-includes/plugin.php(465): WP_Hook->do_action(Array)
    #5 ../wp-includes/post.php(6351): do_action(‘clean_post_cach…’, 649, Object(WP_Post))
    #6 ../wp-includes/post.php(3834): clean_post_cache(Object(WP_Post))
    #7 ../plu in ../wp-includes/author-template.php on line 346

    Plugin Author Kuba Mikita

    (@kubitomakita)

    Thanks, but it doesn’t seem it’s caused by Easy Watermark. WP Super Cache reports it.

    Nonetheless we’ll check it.

    Plugin Author Kuba Mikita

    (@kubitomakita)

    There was certainly an issue with caching plugins. We fixed that in version 1.0.1.

    Now, if you see multiple watermarks in Tools -> Easy Watermark, then the migration wasn’t done correctly. Sorry for the issue, but we advise to update the Easy Watermark plugin, uninstall it and install it again and create your watermarks.

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Updating the new version 1.0.0 Crashed my site’ is closed to new replies.