Support » Plugin: WP-Strava » Updating Settings Failure

  • Resolved csgaraglino

    (@csgaraglino)



    I am trying this on a different site I own and when I full out the Settings Page and hit save, I get the following error:

    {“message”:”Bad Request”,”errors”:[{“resource”:”Application”,”field”:”redirect_uri”,”code”:”invalid”}]}

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author jrfoell

    (@jrfoell)

    Hi csgaraglino,

    I’m not sure what version you’re on currently, but some had conflicts with PHP versions and with the Strava API itself. I updated the plugin to 1.2.0 today which has several fixes and updates. Can you update, try it out, and give some feedback?

    Plugin Author jrfoell

    (@jrfoell)

    Looking at this error, can you double check that the URL you added to your strava app matches that of your site? If you go here https://www.strava.com/settings/apps and click “Visit Website” it should take you to your WP site.

    If it doesn’t, you’ll need to re-authorize by clicking “Revoke Access” on that same Strava / Settings / My Apps page. Then remove, save, and re-add your authorization at /wp-admin/options-general.php?page=wp-strava-options on your WP site.

    I’m on PHP v7.0.25

    The web link is working
    The App is showing up in the App List properly
    All the Keys are correct and I get a Successfully Authorizes message

    How ever, I get
    ERROR 401 Unauthorized – See full error by adding define( ‘WP_STRAVA_DEBUG’ true ); to wp-config.php

    I tried entering the the define string as you have it that caused a 500 error so I added in the missing coma and it still does not give me any more information?

    https://www.mylifeontwowheels.com/bob-yak-trailer/

    Plugin Author jrfoell

    (@jrfoell)

    Thanks csgaraglino, I had this same issue creep up as well. Can you go into the widgets panel and click ‘save’ again on the widget that is throwing that error? I believe it may have an old access token.

    That worked, thanks!

    Plugin Author jrfoell

    (@jrfoell)

    Good find, I’m missing a comma! 🙁 I’ll do a quick update.

    Sweet – can you look at the other ticket that is giving me a Google API Map Error?
    https://wordpress.org/support/topic/no-data-errors/#post-9764993

    I get this fixed, I can launch this weekend!!

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Updating Settings Failure’ is closed to new replies.