WordPress.org

Forums

[resolved] Updating sends iPhone Elsewhere (11 posts)

  1. David_1
    Member
    Posted 10 months ago #

    Hello Friends,

    I just updated and have the Twentyfourteen going.

    It seems to be fine on my desktop browser but unfortunately when I look at my website: http://i-brand.ca/ on my iPhone 4s, my site does not appear but rather an undesirable (mobile) website loads instead.

    If anyone has any ideas what is causing this, I would be extremely grate full to hear from you.

    I ran the copy of Twentyfourteen through the WP Virus checker and all seems fine.

    Thank you very kindly for your help.
    I truly appreciate any and all thoughts and ideas.

  2. esmi
    Forum Moderator
    Posted 10 months ago #

    my site does not appear but rather an undesirable (mobile) website loads instead

    That's exactly the way in which the theme was designed to work. It's a responsive theme, which means that the layout is adjust for smaller, mobile, devices. Perhaps you would be happier choosing another, non-responsive, theme?

  3. David_1
    Member
    Posted 10 months ago #

    Hi Esmi,

    I think I might have explained the situation wrong. When I said an undesireable (mobile) website, I meant that when I view my website now on (my) iPhone it now goes to a different website, not my website.

    Near as I can see, it is loading additional URL data after http://i-brand.ca/ -And sending the user to a completely different site.

    this is where it is going though I expect this will be deleted from my post and I understand why.

    http://i-brand.ca/ on iPhone goes to: http://i-brand.ca/m.textdating.ca|landers/mobile/|113/index.php?keyword=|FRWLD&clickid=2844.ca3g

  4. esmi
    Forum Moderator
    Posted 10 months ago #

    it now goes to a different website, not my website

    Ah! This might be a "feature" offered by your hosts as part of your hosting package. Try asking them about it.

  5. David_1
    Member
    Posted 10 months ago #

    I suppose it could be.(?)

    It seems odd though that prior to the download everything was fine.

    Now it seems I cannot switch back to TwentyThirteen either. Which is what I was using prior to the download of TwentyFourten.

    I am getting the prompt:

    Broken Themes
    The following themes are installed but incomplete. Themes must have a stylesheet and a template.

    Name Description
    Twenty Thirteen Template is missing.

  6. David_1
    Member
    Posted 10 months ago #

    Sorry,

    Forgot to add that FTP indicates that TwentyThirteen files are all there and complete.

  7. esmi
    Forum Moderator
    Posted 10 months ago #

    Try contacting your hosts.

  8. David_1
    Member
    Posted 10 months ago #

    I will call them and inquire.

    Thanks Esmi

  9. David_1
    Member
    Posted 10 months ago #

    Hello Friends,

    There was eveidence of two malicious scripts (maybe) malware who knows that found there way into the WordPress index page and .htacess.

    That said, I do not know where they came from. I think it is likely they came through a plugin when I downloaded the TwentyFourteen.

    Once I had the server cleaned, I downloaded and started with a new database also.

  10. esmi
    Forum Moderator
    Posted 10 months ago #

    Sorry to hear that you were hacked. :-(

    It might be worth reviewing http://codex.wordpress.org/FAQ_My_site_was_hacked just to make sure that the site has been completely de-loused.

  11. David_1
    Member
    Posted 10 months ago #

    Hi Esmi,

    Thanks for your sentiments.
    These things happen, thank you very kindly for these links. I will definitely make use of them!

    Thanks again! ;o)

Reply

You must log in to post.

About this Topic