• Hi, there was an issue about “cannot updating without disable the Toolset Types” in previous years, and this problem seems to be arisen again. So, I cannot update the plugin without disabling first.

    • This topic was modified 4 months, 1 week ago by  AlpDmr.
Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Beda

    (@bedas)

    Yes, it is still present in 2.2.15 as well.

    The solution as well there is:
    1. Deactivate Types
    2. Update Types
    3. Reactivate Types

    In the new version (2.2.15.1) this should be solved for good.

    I was trying to update from version 2.2.14 to 2.2.15.1 and I received the response:

    Toolset Types cannot update because your site’s registration is not valid. Please register Toolset again for this site first.

    I followed your suggestion above: deactivate, update, then reactivate. That worked. But, it appears that version 2.2.15.1 is still having problems.

    Or, is it now a requirement for the user to register the site with Toolset?

    Thanks

    Plugin Author Christian

    (@christianglingener)

    No, it’s not required to register Types.

    After the update it can be that the cache is still outdated. The message should be gone after 24 hours or you can manually update the cache by following these steps: WP Admin -> Dashboard -> Updates and click on the button “Check Again”.

    Best,
    Christian

    Ok many thanks for the explanation.

    Hello, I followed your step by step and could update the plugin. Many thanks!

    Hi, upgrading to the latest version of Types (2.2.16) created a string of errors on my plugins page, mainly:
    Warning: Invalid argument supplied for foreach() in /home/content/52/9022552/html/wordpress/wp-content/plugins/types/vendor/otgs/installer/includes/class-wp-installer.php on line 308

    Warning: Invalid argument supplied for foreach() in /home/content/52/9022552/html/wordpress/wp-content/plugins/types/vendor/otgs/installer/includes/class-wp-installer.php on line 2255

    Deactivating the plugin clears the errors, reactivating it they re-appear.
    Running latest WordPress install, with Moesia theme. All other plugins are updated to latest versions too.

    Can you provide any assistance in terms of clearing this issue? Thanks! 🙂

    **UPDATE: I have temporarily reverted to v2.2.10 which works fine. Would love to be able to use most current version though. **

    • This reply was modified 3 months, 2 weeks ago by  insaneyjaney.
    Plugin Support Beda

    (@bedas)

    This ticket is a sticky Post, for a very specific issue, @insaneyjaney

    It is not the issue you experience

    Please open your own, new ticket, then I can assist

    Thank you

    Hello, I have the problem of the OP, if I desactivate and reactivate Toolset types I won’t lose any settings’data on my websites ? Thank you.

    Moderator keesiemeijer

    (@keesiemeijer)

    moderator

    Hi @makeonlineshops

    Please create your own topic if it doesn’t work for you.
    https://wordpress.org/support/plugin/types/#new-post

    Forum Guidelines

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Updating Problems’ is closed to new replies.