WordPress.org

Forums

Quick Cache (Speed Without Compromise)
updating post gives a quick cache php error (8 posts)

  1. jy33
    Member
    Posted 8 months ago #

    Hi Raam,
    Since latest upgrade I have to disable the cache to avoid error when I update the posts. Also, I got now sporadically internal server error when I try to navigate the page (often once then ok after).
    I tried to remove and reinstall quick cache without success.
    I have no more info to help as the error is always reproducible without any special handling.
    If I find something more I will post it ..

    The error is the same as I posted previously in an other stream :

    [31-Jul-2014 21:10:42 UTC] PHP Fatal error: Uncaught exception 'InvalidArgumentException' with message 'RegexIterator::__construct(): Unknown modifier 't'' in /home/jeanyves/domaines/dev33/wp-content/plugins/quick-cache/includes/share.php:918
    Stack trace:
    #0 /home/jeanyves/domaines/dev33/wp-content/plugins/quick-cache/includes/share.php(918): RegexIterator->__construct(Object(RecursiveIteratorIterator), '/^\/home\/jeany...', 0, 1)
    #1 /home/jeanyves/domaines/dev33/wp-content/plugins/quick-cache/quick-cache.inc.php(1069): quick_cache\share->dir_regex_iteration('/home/jeanyves/...', '/^\/home\/jeany...')
    #2 /home/jeanyves/domaines/dev33/wp-content/plugins/quick-cache/quick-cache.inc.php(973): quick_cache\plugin->auto_purge_xml_sitemaps_cache()
    #3 [internal function]: quick_cache\plugin->auto_purge_post_cache(26)
    #4 /home/jeanyves/domaines/dev33/wp-includes/plugin.php(470): call_user_func_array(Array, Array)
    #5 /home/jeanyves/domaines/dev33/wp-includes/post.php(5315): do_action('clean_post_cach...', 26, Object(WP_Post))
    #6 /home/jeanyves/domaines/dev33/wp- in /home/jeanyves/domaines/dev33/wp-content/plugins/quick-cache/includes/share.php on line 918

    https://wordpress.org/plugins/quick-cache/

  2. Raam Dev
    Member
    Plugin Author

    Posted 8 months ago #

    Can you tell me what version of PHP you are running please?

  3. jy33
    Member
    Posted 8 months ago #

    Hi Raam,

    For the internal server error (500) I got this php error :

    [31-Jul-2014 21:44:35 UTC] PHP Fatal error: Allowed memory size of 1585446912 bytes exhausted (tried to allocate 4120309121 bytes) in /home/jeanyves/domaines/dev33/wp-includes/plugin.php on line 850

    This error does not appear if quick cache is disabled.

    Thanks,
    Jean-Yves

  4. jy33
    Member
    Posted 8 months ago #

    php version is 5.4.25

  5. Raam Dev
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Jean-Yves,

    Can you please tell me if your wp-config.php file has any memory limits specified? You can see how to do that here: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    Also, you might want to contact your web host and ask them if there are memory issues on your server. If you're running on a shared hosting server, the server itself may be low on system resources and causing these problems.

    Regarding the error when you update posts: Does the error happen every time? Is the error that you're seeing the first one you posted above (PHP Fatal error: Uncaught exception)?

  6. jy33
    Member
    Posted 8 months ago #

    Hi Raam,
    Thanks for your answer.
    The wp-config.php file does not contain memory limitation. Only the database access parameters were modified in that file.
    The web host responded that there is no memory issue.
    PHP Fatal error: Uncaught exception is the first error I saw.
    It looks that server error appear more often when I disable then enable the quick cache. Does not work every times.
    JY

  7. jy33
    Member
    Posted 8 months ago #

    Hi Raam,
    I have to give up quick cache now unusefull.
    I have really no idea where to search for this issue.

    regards,
    Jean-Yves

  8. Raam Dev
    Member
    Plugin Author

    Posted 8 months ago #

    Hi Jean-Yves,

    I'm sorry to hear that. Since I'm not able to recreate this issue, I have to assume that it's related to a configuration that is specific to your web host.

Reply

You must log in to post.

About this Plugin

  • Quick Cache (Speed Without Compromise)
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic