Support » Plugin: WooCommerce Product Addons » Updating plugin does not add new fields to table

  • Hi,
    Bought and updated the plugin from v3.1 to v8.1. Export/Import of metadata fails – (it appears that additional fields in table nm_personalized were not added when installing later version).
    Update: Having looked at the codex, I believe the reason is “Since 3.1 the activation function registered with register_activation_hook() is not called when a plugin is updated…” see https://codex.wordpress.org/Creating_Tables_with_Plugins

    Can you fix this please? (wihout wiping our existing data of course!)
    Thanks

    • This topic was modified 8 months, 3 weeks ago by  chrishe. Reason: additional information
    • This topic was modified 8 months, 3 weeks ago by  chrishe.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author nmedia

    (@nmedia)

    Hi,

    Sorry, but you updating from old version to latest. We have released many major release between 3.1 to 8.1. So it might not be possible to direct import from 3.1 to latest.

    Yes, I understand 3.1 very old version, but I expected when 8.1 installed it would add the correct new fields (obviously unpopulated). Thus after installing v8.1, exporting as csv and then importing back again should work I would have thought, but it doesn’t, as 10 field headers are exported but only 8 values for each record.
    Regards

    Plugin Author nmedia

    (@nmedia)

    I think we have added some columns in some middle version and these are missed while import/export in two such different version.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Updating plugin does not add new fields to table’ is closed to new replies.