Support » Plugin: Gutenberg » Updating or deactivating Gutenberg breaks website

  • This website was built using Oxygen Builder. It is about 2 years old and the owner had not maintained it. Oxygen Builder now supplies its own licensed plugin to support Gutenberg which I want to use, but deactivating or deleting this Gutenberg plugin breaks the site. All other plugins update without issue. I did not attempt to upgrade to WP 5.5. It is running This the error message which shows on the front of the website (dashboard is fine):
    Fatal error: Uncaught Error: Class ‘WP_Block_Styles_Registry’ not found in /home/xxxxxxx/public_html/wp-includes/script-loader.php:2903 Stack trace: #0 /home/xxxxxx/public_html/wp-includes/class-wp-hook.php(288): enqueue_block_styles_assets(”) #1 /home/xxxxxx/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #2 /home/military/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #3 /home/xxxxxx/public_html/wp-includes/script-loader.php(2857): do_action(‘enqueue_block_a…’) #4 /home/xxxxxx/public_html/wp-includes/class-wp-hook.php(288): wp_common_block_scripts_and_styles(”) #5 /home/xxxxxx/public_html/wp-includes/class-wp-hook.php(312): WP_Hook->apply_filters(NULL, Array) #6 /home/xxxxxx/public_html/wp-includes/plugin.php(478): WP_Hook->do_action(Array) #7 /home/xxxxxx/public_html/wp-includes/script-loader.php(2671): do_action(‘wp_enqueue_scri…’) #8 /home/xxxxxx/public_html/wp-includes/class-wp-hook.php(288): wp_enqueue_scripts(”) #9 /home/xxxxxx/publi in /home/xxxxxx/public_html/wp-includes/script-loader.php on line 2903

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Riad Benguella

    (@youknowriad)

    Hi there! Sorry for the issues.

    Would you mind sharing what WordPress version you’re using?

    This error message “WP_Block_Styles_Registry not found” suggests that some of your plugins might be using this class which was added to WordPress Core on WordPress 5.3. Is it possible that this site is on an older version? The Gutenberg plugin also provides this class and this might explain why disabling it causes the error to appear.

    HI,

    It’s 5.3.4.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.