Support » How-To and Troubleshooting » [Resolved] Updating never ends

[Resolved] Updating never ends

  • I updated to 3.0 and tried to run some auto-updates for themes/plugins, but it seems to hang forever and never finish updating (or possibly it is just taking a looonnnnnggggg time).

    I took a peek at what was going on in my FTP listing and it looks like it created a file in the “wp-content” folder with the name of one of the things it’s updating, but even after some time it is still 0 bytes in size (according to my FTP app).

    I tried canceling the update, deleting the temp file and the .maintenance file, then CHMODding the entire “wp-content” folder recursively to 777, but it didn’t seem to have any effect.

    Anything I can do to fix this? Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • I’m getting the exact same problem. Can’t update plugins, can’t install new themes, etc. It either gives me a blank screen (still with the menu, header, etc. but no content) or it will occasionally show that it has downloaded and is unpacking the package, but it never gets any further. Never any error messages or timeouts, my browser just says “done”.

    I’ve experimented on different computers, browsers, and internet connections with no luck. I even tried completely uninstalling and reinstalling WordPress. The weird part is, it seems to be affecting all of the blogs I host. Could it be something to do with my webhost?

    Would really love some help or ideas on this as it’s put quite a kink in the progress of my new blog. Thanks!

    I think, in your case, you can definitely be sure it’s your webhost. WordPress has to have permission to create files on your server, add data to them, move them around, etc. And since almost all of this is done with server-side code, chances are different computers/browsers won’t have much of an effect.

    In my case I never get past this screen… Does anyone have any tips or suggestions?

    I’m having the same problem mxrider108 is too. While trying to upgrade automatically, my dashboard has read “Downloading update from http://wordpress.org/wordpress-3.0.zip.” for at least the last 36 hours. I’ve tried refreshing, but the message stays the same.

    Any ideas?


    FWIW – I have the same problem. I’m very new though, so don’t have much to add. It worked once for a plugin – but never again for anything else. I’m getting proficient with cyberduck and my cpanel though. . .

    Probably better that way?

    Some follow-up on my problem, I thought the problem might be that my WP’s were installed through Fantastico, but a fresh manual install with the official WP zip file still didn’t resolve the problem.

    I also tested the problem on some of my older blogs on the same host, which are WordPress versions 2.9.2 and 2.8.6, and the problem was still there. This is looking more and more like a problem with my web host, since it seems to have appeared suddenly and absolutely no variables, including WordPress version or method of installation, seem to change it.

    I’ve submitted a support ticket to my webhost about the issue. If I get any feedback, I’ll report back here!


    I let mine try to update for several hours last night before closing my browser and going to sleep/work. I just checked back and the blog is no longer in maintenance mode and says “An automated WordPress update has failed to complete – please attempt the update again now” at the top of the page in the admin panel.

    Does anyone know how I can debug this further? Is there a log I can check somewhere to see where/how it failed?


    Moderator James Huff


    Your server error log may have more information, but its location varies depending on your hosting provider.

    Try disabling all plugins before upgrading. If that doesn’t work, you may need to increase PHP’s memory allocation.

    First, try installing the Memory Bump plugin.

    If that doesn’t work, here are four ways to increase PHP’s memory allocation:

    1. If you have access to your PHP.ini file, change the line in PHP.ini
    If your line shows 32M try 64M:
    memory_limit = 64M ; Maximum amount of memory a script may consume (64MB)
    2. If you don't have access to PHP.ini try adding this to an .htaccess file:
    php_value memory_limit 64M
    3. Try adding this line to your wp-config.php file:
    Increasing memory allocated to PHP
    define('WP_MEMORY_LIMIT', '64M');
    4. Talk to your host.

    Thanks for the helpful post, maxmanx! It turns out the main reason for the hanging I was experiencing was due to one of my themes (I guess the update server for that theme was unreachable or exceedingly slow)…

    Moderator James Huff


    You’re welcome!

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘[Resolved] Updating never ends’ is closed to new replies.
Skip to toolbar