Support » Plugins and Hacks » updating my plugin for 2.5

  • sccr410

    (@sccr410)


    http://wordpress.org/extend/plugins/aws-easy-page-link

    This plugin uses the external link list feature of TinyMCE – http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/external_link_list_url

    How that works did not change in v3 of TinyMCE, so I assumed I wouldn’t really have to do anything. Then I found that in 2.5 that the action ‘tinymce_before_init’ has become a new filter ‘tiny_mce_before_init’.

    Previously I had this code:

    add_action(‘tinymce_before_init’, ‘AWS_easy_page_head’);

    I changed that to:

    add_filter(‘tiny_mce_before_init’, ‘AWS_easy_page_head’);

    I assumed this would then work for 2.5 – no go, the TinyMCE basically doesn’t load at all now. That was all the docs I could find, so I’m pretty lost on what else to try or why it doesn’t work anymore.

  • The topic ‘updating my plugin for 2.5’ is closed to new replies.