Support » Plugin: MailPoet - emails and newsletters in WordPress » Updating Mailpoet 3 breakes WordPress website

  • Resolved PedroDK

    (@pedrodk)


    Hi,
    I read that you request info on error messages after updating Mailpoet 3.

    Updating Mailpoet 3 returns the awful WSOD.

    Here’s a massive one: (I substituted website name with “websitename”)

    Fatal error: Uncaught IdiormMethodMissingException: Method getValue() does not exist in class ORMWrapper in /var/www/websitename/public_html/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php:2271 Stack trace: #0 /var/www/websitename/public_html/wp-content/plugins/mailpoet/vendor/j4mie/paris/paris.php(699): ORM->__call(‘getValue’, Array) #1 /var/www/websitename/public_html/wp-content/plugins/mailpoet/lib/Models/Model.php(332): Model::__callStatic(‘getValue’, Array) #2 /var/www/websitename/public_html/wp-content/plugins/elementor-pro/modules/forms/actions/mailpoet3.php(56): MailPoet\Models\Model::__callStatic(‘getValue’, Array) #3 /var/www/websitename/public_html/wp-content/plugins/elementor-pro/modules/forms/widgets/form.php(706): ElementorPro\Modules\Forms\Actions\Mailpoet3->register_settings_section(Object(ElementorPro\Modules\Forms\Widgets\Form)) #4 /var/www/websitename/public_html/wp-content/plugins/elementor/includes/base/controls-stack.php(1920): ElementorPro\Modules\Forms\Widgets\Form->_register_controls() #5 /var/www/websitename in /var/www/websitename/public_html/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php on line 2271

    Thanks

    P.

Viewing 8 replies - 1 through 8 (of 8 total)
  • We have passed an identical case, is broken in integration with elementor pro. By deactivating it, the web has returned to work correctly.

    Plugin Author MailPoet

    (@wysija)

    Hey @pedrodk and @bernietorras,

    There’s a bug in the Elementor Pro plugin. Specifically, the Elementor Pro plugin uses core MailPoet methods rather than the just the API.
    In MailPoet 3.19.0 some of these methods got refactored and modified. This results in the Elementor Pro plugin throwing a fatal error.

    We’ve reached out to the Elementor developers with specific details so they can fix their integration.

    In the meantime, we’d recommend downgrading MailPoet to 3.18.2 until Elementor has fixed their integration as this is not something that can be fixed on our side.

    You can download older versions of the plugin at the bottom of the page here: You can download older versions by going to the bottom of the page here: https://wordpress.org/plugins/mailpoet/advanced/

    Thanks!

    thank you soo much. Great. Have a nice day

    Hi

    I got also problems with MailPoet Bouncehandler
    After starting that I get the following errors
    #7 {main}
    thrown in /www/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php on line 2271
    [07-Feb-2019 14:23:06 UTC] PHP Fatal error: Uncaught IdiormMethodMissingException: Method getValue() does not exist in class ORMWrapper in /www/wp-content/plugins/mailpoet/vendor/j4mie/idiorm/idiorm.php:2271
    Stack trace:
    #0 /www/wp-content/plugins/mailpoet/vendor/j4mie/paris/paris.php(699): ORM->__call(‘getValue’, Array)
    Any Idea to solve this ?
    I need this plugin by the end of next week !
    I have no Elementor plugin installed !

    Regards,
    Peter

    Same thing happening here, with MailPoet Bouncehandler….

    No Elementor plugin either,
    thanks,
    Matt

    Both! 🙁 Bouncehandler Issue + Elementor Pro Issue

    Plugin Author MailPoet

    (@wysija)

    Hi All,

    For any issues related to another third party-plugin compatibility with MailPoet, please start a new topic so we can keep track and properly assist you.

    Thanks!

    Plugin Author MailPoet

    (@wysija)

    Hey everyone,

    Just to let you know we’ve made minor adjustments to assist third-party plugins using MailPoet integrations, including Elementor Pro plugin, in the latest release 3.19.1.

    It should be working now.

    Thanks for your patience.

Viewing 8 replies - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.