Support » Plugin: Gutenberg » Updating Failed

  • Resolved Mike Clayton

    (@mike-clayton)


    Lots of closed reports on this – but still happens to me.

    It is sporadic. I get the red bar that says that updating failed. The only way to get back to saving work is to reload the page. This often loses a few minutes of edits.

    This means a need to copy the text to a plain text edit app, then repaste bits into the blocks, extracting html as I go.

    I use Wordfence, W3 Total Cache and Thrive Themes.

    Please, please, please DO NOT launch this as a mandatory part of WP until you fix this. I am reverting to the old editor.

Viewing 15 replies - 1 through 15 (of 22 total)
  • Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    There really isn’t anything to be fixed. This isn’t an error in the editor, it’s an error on your server. Check the server error logs and see why it is failing in these requests.

    Well, I never have the error with the standard editor, Otto, so while I bow to your greater expertise, I will stick with the old editor, which never throws up this or a comparable problem. The only thing I changed is activating a plugin, so it does seem plausible that the plugin has a fault or a feature that is in some way connected. Now it is deactivated, all is well again.

    It seems to me if WP is planning a huge release, and has issued a plugin so people can test it, then there is a possibility the code is not perfect. And if the code is perfect and it doesn’t work right, with my host’s server, then I doubt I am alone.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    The old editor doesn’t work the same way the new one does, so tests like releasing this plugin to the world for a year in advance are necessary to work out those types of kinks.

    Realistically, if your server is throwing errors because of the REST API calls, then we need to know what those errors are, and potentially who your hosting service is, to be able to get them fixed before releasing the editor into the wild.

    I just installed and launched this editor today (9/08/18) and from the start this same error popped up. I am using the Chrome browser and when I have time, I will test Gutenberg on other browsers.

    Pros: I love the ease of use and finally, more formatting options without resorting to numerous plug-ins. Gutenberg makes posting less of a task and this puts fun into the process, not just the result.

    The only “Con” and it’s significant to me, is this error that caused me to lose my work. I rewrote it and began copy/pasting as I tried to get a draft to save and even took the risk to just click Publish, hoping that would work. I got the red “Failure to Update” error each time.

    Finally, I reverted to Classic Editor and pasted my post there. It saved my drafts and published as it always did.

    I love the idea of this editor and welcome the change to the limited, existing CE. Once I find consistent failure to save drafts and publish has been eliminated, I will probably return.

    Keep up the good work!

    I’ve installed and played with the Gutenberg editor on several sites hosted on SiteGround, Dreamhost and GoDaddy. Not only could I not even activate the plugin on the GoDaddy site until I turned off ALL other plugins, I had this same problem with failure to publish. GoDaddy tech asked why I wanted to use the editor because he said it “never works” and he “always” got that failure to update error. So I’m suspecting a server problem as well.

    I am having the same issues as @mercedeslady. I spent so many hours on a new blogpost that not only wouldn’t publish, it didn’t save when it said it did.Lost the whole thing.

    Hi @kerchmcc, would you mind posting a list of the plugins you have installed on that site? It sounds like there’s a conflict between one (or more) of them and Gutenberg. If I knowing which plugins are installed will help narrow down the issue.

    —-

    @christinekohut, gosh I’m sorry, that sounds awful 🙁

    Would you mind letting me know what plugins you have installed as well? If I can reproduce the problem, that will lead to a bug fix, which will prevent other people from experiencing the same problem.

    I’m teaching a class on basic WordPress at a local Community College. Every student is encountering the same issue trying to update/publish posts and pages using the Gutenberg editor. I told them to use the classic editor which works fine.

    The sites are being hosted on Bluehost. All sites are fresh installs with default plug-ins.

    • This reply was modified 1 year, 3 months ago by Dale Rogers.
    • This reply was modified 1 year, 3 months ago by Dale Rogers.

    Hi @dalerrogers, are your students using their option laptops, or is it a computer lab where each machine has identical hardware and software?

    Assuming it’s the latter, could you let us know the browser name and version number? Also, does the browser have any 3rd-party extensions installed?

    Hi @iandunn. Thanks for responding. Both situations exist. Since WordPress is web based, students are free to use their laptops if they bring them to class. Most use the classroom computers which are iMacs with identical setups. Since it’s a Web Design program, the desktops are equipped with Safari, Firefox, and Chrome browsers. I believe the default browser is Safari, but students are free to use the one of their choice. The browsers would not have 3rd party extensions installed. All software licenses and user agreements have to be approved by the Tennessee Board of Regents legal department. Consequently we tend to have fairly vanilla installations. No offense to vanilla intended.

    • This reply was modified 1 year, 3 months ago by Dale Rogers. Reason: misspelling

    Hmmm, ok. Are you noticing any errors or warnings in the browser console? That might help track it down.

    Moderator Marius L. J.

    (@clorith)

    I’m going to butt in here real quick.

    Please check your JavaScript Console for any errors when it fails to save, it’ll often include the failure code which may give us a better understanding of what is going on.
    You may find steps on how to do that in step #3 of the article on JavaScript debugging.

    I’d also like to ask that we move this off into a new topic, as you’re causing a whole lot of notification emails to go out to the other participants on another users topic by taking it over like this.

    Will do. @iandunn I just sent you an email.

    theskipper

    (@theskipper)

    Using Gutenberg on the latest Ffx on Ubuntu, I get the following every 10 seconds in my Apache logfile:
    “POST /wp/index.php/wp-json/wp/v2/posts/5/autosaves?_locale=user HTTP/1.1” 404
    So the regular ‘save’ is receiving a 404 each time.

    Is this the cause of all the problems?

    theskipper

    (@theskipper)

    Yes it was .. I think my Apache was ignoring the .htaccess file and so failing to rewrite the request string. I put

    `<Directory /var/www/html/wp>
    AllowOverride All
    </Directory>`

    in my apache2.conf file, restarted the server and hey presto!

    (All my WordPress stuff is in subdirectory wp/.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Updating Failed’ is closed to new replies.