Support » Fixing WordPress » Updating failed when you save Post in WP5

  • I updated WP5 today and tried to post; but its not saving.

    it shows Auto saved but nothing saves

    TAG option is not visible.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Im using WP for decade but this is WORST code i ever seen, instead speedingup it slow down whole site

    on my 2nd site i cannt see visual/code editor option at all

    instead making it simple team made it complicated

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You have something blocking the REST API calls on your site.

    – If you have a “security” plugin, try turning it off.
    – If you have any rules in your .htaccess that reference “wp-json”, then remove those rules.
    – Visit the Settings->Permalink page and resave your permalink settings.

    These are the known fixes for this specific problem.

    I get the update failed error message, but it seems that the changes have taken effect, anyway. In other words: it says it failed, but it seems to have succeeded.

    In trying to disable a plugin, though, the opposite happened: I got a “success” message that it was deactivated, but it wasn’t. Not until I manually removed the file from the FTP server.

    I was worried about this, which is why I have updated only one site to WP5 of the dozens I manage.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @jamesdonegan Generally speaking, we prefer people to start new topics with their issues instead of posting in other people’s topics. It helps keep things cleaner.

    I wasn’t trying to introduce a new issue. I mentioned the plugin thing as an aside. My point was that it might be generating an error message, but that the post might, in fact, be updating correctly.

    If you have a “security” plugin, try turning it off.
    //I know there is problem with WORDFENCE but i dont use it. i have only SPAM BLOCKER and i cannt afford to block it.
    – If you have any rules in your .htaccess that reference “wp-json”, then remove those rules.
    //No rules set in .htaccess as i have not edited anything to .htaccess for ages. than some russian/chinese IPs
    – Visit the Settings->Permalink page and resave your permalink settings.
    //I cannt change Permalinks as all posts URL listed in many other sites / sitemaps / Google will fail
    ————————
    any major upgrade should not affect with so many issues. i added classic editor all is ok for time being.

    i checked ERROR log no issue reported. instead Developer shld focus how to make WORDPRESSer life easy with additional tools but not with these kind of fancy tweeks.

    WHY NOT WORDPRESS IS ADDING SOME VERY USEFULL PLUGIN FEATURES IN ITS CORE?

    I also get “Update failed” but not only that – I can’t even close the browser tab on the page. Weirdly the updates have actually saved so that’s a small positive end note. Anyone discovering this? I have to close the entire browser to start again. UGH!!!

    Why did WP do this when we have so many page builders out there? 90% of my site use Visual Composer. Was the aim to kill that market? Foolish update. “If it works don’t fix it”

    Every time I try to close the tab in Chrome, I see a javascript box pop-up saying “Changes may not be saved” – but they are. So…

    paulusbaz

    (@paulusbaz)

    I also have this issue with WordPress 5.0.3.
    Symptoms:
    – if I have permalinks set to Plain, I can save pages
    – if I have permalinks set to ‘Post name’, when I save a page I get ‘Updating failed’

    In my Chrome console I get this:
    GET https://www.myservername.com/wp-json/wp/v2/users/?who=authors&per_page=100&_locale=user 404 (Not Found)

    GET https://www.myservername.com/wp-json/wp/v2/taxonomies?per_page=100&context=edit&_locale=user 404 (Not Found)

    I’ve tried deleting .htaccess and letting it get recreated when I save the permalinks, and it currently contains this:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    This is on a fresh Ubuntu 18.04.1 server with apache2 2.4.29-1ubuntu4.5, although the site is from a backup from another server.
    We have a Lets Encrypt certificate installed using the certbot, in case that is a factor.

    Other plugins installed:

      Akismet Anti-Spam
      Page Builder by SiteOrigin
      SiteOrigin CSS
      SiteOrigin Premium
      SiteOrigin Widgets Bundle
      UpdraftPlus – Backup/Restore
      wpForo

    Many thanks for any help you can give on this.

    We are getting the same issue. We suddenly can’t make updates to blog posts. Completely out of the blue. We made no changes to any plugins, no system updates, nothing. Just all of a sudden every post update fails. We will be trying some of the steps on this page…

    I (as an admin) can update any post in our site with no problems. But my two authors are each having the utterly useless “Update Failed” error. You’d think in 2019, an error message could generate a BIT more useful information than that? No? Ah, one can only dream…

    Okay! I’m a genius. It turns out authors can not edit. They can only author. They need to have the Editor role in order to edit. I feel stupid. And I am stupid. BUT:

    Would it kill a developer to show an error message that says, “Your role does not allow this action” instead of “Update Failure”? C’mon, now.

    Hi friends, I am shocked when I have written down my whole post and wordpress autosave functionality did not work.
    and then I loss my whole post.
    But Got my solution You can check it out here:
    How to solve Updating failed in WordPress 5

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.