Support » Fixing WordPress » Updating failed when you save Post in WP5

  • I updated WP5 today and tried to post; but its not saving.

    it shows Auto saved but nothing saves

    TAG option is not visible.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Im using WP for decade but this is WORST code i ever seen, instead speedingup it slow down whole site

    on my 2nd site i cannt see visual/code editor option at all

    instead making it simple team made it complicated

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    You have something blocking the REST API calls on your site.

    – If you have a “security” plugin, try turning it off.
    – If you have any rules in your .htaccess that reference “wp-json”, then remove those rules.
    – Visit the Settings->Permalink page and resave your permalink settings.

    These are the known fixes for this specific problem.

    I get the update failed error message, but it seems that the changes have taken effect, anyway. In other words: it says it failed, but it seems to have succeeded.

    In trying to disable a plugin, though, the opposite happened: I got a “success” message that it was deactivated, but it wasn’t. Not until I manually removed the file from the FTP server.

    I was worried about this, which is why I have updated only one site to WP5 of the dozens I manage.

    Moderator Samuel Wood (Otto)

    (@otto42)

    WordPress.org Admin

    @jamesdonegan Generally speaking, we prefer people to start new topics with their issues instead of posting in other people’s topics. It helps keep things cleaner.

    I wasn’t trying to introduce a new issue. I mentioned the plugin thing as an aside. My point was that it might be generating an error message, but that the post might, in fact, be updating correctly.

    rudy3107

    (@rudy3107)

    If you have a “security” plugin, try turning it off.
    //I know there is problem with WORDFENCE but i dont use it. i have only SPAM BLOCKER and i cannt afford to block it.
    – If you have any rules in your .htaccess that reference “wp-json”, then remove those rules.
    //No rules set in .htaccess as i have not edited anything to .htaccess for ages. than some russian/chinese IPs
    – Visit the Settings->Permalink page and resave your permalink settings.
    //I cannt change Permalinks as all posts URL listed in many other sites / sitemaps / Google will fail
    ————————
    any major upgrade should not affect with so many issues. i added classic editor all is ok for time being.

    i checked ERROR log no issue reported. instead Developer shld focus how to make WORDPRESSer life easy with additional tools but not with these kind of fancy tweeks.

    WHY NOT WORDPRESS IS ADDING SOME VERY USEFULL PLUGIN FEATURES IN ITS CORE?

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.