Support » Fixing WordPress » “Updating Failed” when updating pages

  • Hi there,

    So I’ve been able to use my WordPress site and theme for long enough to set it up etc. However recently I’ve been trying to update my site to no avail.

    I’m getting a very simple but generic “Updating Failed” error every time I hit Update on my pages.

    At first I thought it may have been because of a plugin I installed (I think called Use Any Font), where I think I remember having to edit a file in the directory (maybe htaccess?). I have since uninstalled it as it wasn’t working.

    Anyway I can’t be sure if this is the reason as I’m not 100% sure if the timing of the problem matches with this plugin. Or if its an update compatibility error… I’ve tried deactivating all my plugins and no luck.

    Here is some Health Check information that I keep seeing people ask for in other threads;

    
    ### WordPress ###
    
    Version: 5.1.1
    Language: en_GB
    Permalink structure: /%category%/%postname%/
    Is this site using HTTPS?: No
    Can anyone register on this site?: No
    Default comment status: open
    Is this a multisite?: No
    User Count: 1
    Communication with WordPress.org: WordPress.org is reachable
    Create loopback requests: The loopback request to your site completed successfully.
    
    ### Installation size ###
    
    Uploads directory: 390.09 MB
    Themes directory: 9.89 MB
    Plugins directory: 55.07 MB
    Database size: 2.47 MB
    Whole WordPress Directory: 876.02 MB
    Total installation size: 878.48 MB
    
    ### Active theme ###
    
    Name: TwoFold
    Version: 3.2.5.1
    Author: fuelthemes
    Author website: http://themeforest.net/user/fuelthemes
    Parent theme: Not a child theme
    Supported theme features: woocommerce, wc-product-gallery-lightbox, custom-background, title-tag, automatic-feed-links, post-thumbnails, html5, nav-menus, menus
    
    ### Other themes (4) ###
    
    Twenty Fifteen (twentyfifteen): Version 2.4 by the WordPress team
    Twenty Nineteen (twentynineteen): Version 1.3 by WordPress Team
    Twenty Seventeen (twentyseventeen): Version 2.1 by the WordPress team
    Twenty Sixteen (twentysixteen): Version 1.9 by The WordPress Team
    
    ### Must Use Plugins (1) ###
    
    Health Check Troubleshooting Mode: Version 1.5.1
    
    ### Active Plugins (7) ###
    
    Contact Form 7: Version 5.1.1 by Takayuki Miyoshi
    Health Check & Troubleshooting: Version 1.2.6 by The WordPress.org community
    Limit Login Attempts: Version 1.7.1 by Johan Eenfeldt
    Sucuri Security - Auditing, Malware Scanner and Hardening: Version 1.8.20 by Sucuri Inc.
    TwoFold - Custom Post Types: Version 1.0.2 by fuelthemes
    UpdraftPlus - Backup/Restore: Version 1.16.11 by UpdraftPlus.Com, DavidAnderson
    WP Statistics: Version 12.6.2 by VeronaLabs
    
    ### Inactive Plugins (5) ###
    
    Akismet Anti-Spam: Version 4.1.1 by Automattic
    Hello Dolly: Version 1.7 by Matt Mullenweg
    Thumbnail Crop Position: Version 1.3 by Javier Gómez Pose
    WooCommerce: Version 3.5.7 by Automattic
    WP-VR-view - Photo Sphere and 360 video: Version 1.6 by Tumanov Alexander
    
    ### Media handling ###
    
    Active editor: WP_Image_Editor_Imagick
    Imagick Module Version: 1656
    ImageMagick Version: ImageMagick 6.7.8-9 2016-06-16 Q16 http://www.imagemagick.org
    Imagick Resource Limits: 
    	area: 252 GB
    	disk: -1
    	file: 768
    	map: 252 GB
    	memory: 126 GB
    	thread: Not Available
    GD Version: bundled (2.1.0 compatible)
    Ghostscript Version: 9.07
    
    ### Server ###
    
    Server architecture: Linux 4.14.68 x86_64
    Web Server Software: Apache
    PHP Version: 7.2.11 (Supports 64bit values)
    PHP SAPI: cgi-fcgi
    PHP max input variables: 1000
    PHP time limit: 60
    PHP memory limit: 256M
    Max input time: 6000
    Upload max filesize: 100M
    PHP post max size: 100M
    cURL Version: 7.61.0 OpenSSL/1.0.2p
    SUHOSIN installed: No
    Is the Imagick library available: Yes
    Htaccess rules: Custom rules have been added to your htaccess file
    
    ### Database ###
    
    Extension: mysqli
    Server version: 5.7.16
    Client version: mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $
    Database prefix: oc8d_
    
    ### WordPress constants ###
    
    ABSPATH: /var/sites/j/jackrhoward.com/public_html/
    WP_HOME: Undefined
    WP_SITEURL: Undefined
    WP_DEBUG: Disabled
    WP_MAX_MEMORY_LIMIT: 256M
    WP_DEBUG_DISPLAY: Enabled
    WP_DEBUG_LOG: Disabled
    SCRIPT_DEBUG: Disabled
    WP_CACHE: Disabled
    CONCATENATE_SCRIPTS: Undefined
    COMPRESS_SCRIPTS: Undefined
    COMPRESS_CSS: Undefined
    WP_LOCAL_DEV: Undefined
    
    ### File system permissions ###
    
    The main WordPress directory: Writable
    The wp-content directory: Writable
    The uploads directory: Writable
    The plugins directory: Writable
    The themes directory: Writable
    The Must Use Plugins directory: Writable
    
    

    Any help would be much appreciated, thanks!

    • This topic was modified 1 month, 1 week ago by  jackrhoward1.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • Moderator t-p

    (@t-p)

    This may be a plugin or theme conflict. Please attempt to disable all plugins, and use one of the default (Twenty*) themes. If the problem goes away, enable them one by one to identify the source of your troubles.

    If you can install plugins, install “Health Check”: https://wordpress.org/plugins/health-check/ On the troubleshooting tab, you can click the button to disable all plugins and change the theme for you, while you’re still logged in, without affecting normal visitors to your site.

    Thanks for this.

    I tried what you said, but I’m still getting the problem.

    Worth noting though that when I try to update the background image on my homepage (of the elephant), it says “Updating Failed” yet when I refresh my live site the update has worked. Doesn’t work for changing text on the “about” page though.

    Moderator t-p

    (@t-p)

    Please check the error logs on your server for a more specific error message, which may give a clue to why this is happening on your website/server. If you are using cPanel, the following tutorial has more information about the error log in cPanel: How to view cPanel Error logs . If you need help locating them, ask your hosting provider to help you with that.

    If you cannot find error logs or if you don’t find any helpful info in the error logs, try Enabling debugging

    Also it wouldn’t hurt to discuss the issue with your hosting provider.

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.