Support » Plugin: Gutenberg » ‘Updating Failed’ Warning on Autosave?

  • Resolved fanalejr

    (@fanalejr)


    Testing out the new Gutenberg plugin – noticing some issues. It appears that I am getting an ‘Updating Failed’ error on autosave. Are you seeing this anywhere else? I’m on the Genesis Framework and this is more of a test site so not a log of plugins active.

    I’m assuming it’s related, but this is also making it impossible to ‘preview’ posts created with Gutenberg. It’s just stuck on Please wait… Generating preview.

    console – https://screencast.com/t/rrv4iD6k2uPK
    autosave error – https://screencast.com/t/DZmwAeBce

Viewing 8 replies - 1 through 8 (of 8 total)
  • I am having exactly the same problem.
    I’m running a Siteorigin Vantage Premium theme.

    One observation: I see the autosave kick in and confirm the draft has been saved. It immediately returns to “Save Draft” even though I haven’t touched the keyboard. I have confirmed that the draft is being saved. I’m still seeing the Updating Error though.

    I have been trying Gutenberg off and on for some time now and do like the way it is coming along. This has been a key reason why I have returned to the old editor.
    Preview is vital, and I expect the preview to function quickly, as it always has. Without it Gutenberg is simply not fit for purpose.

    Moderator Marius L. J.

    (@clorith)

    Hi,

    We are working with CloudFlare on an issue relating to this, so if you are using them for your site please see https://github.com/WordPress/gutenberg/issues/2704#issuecomment-41009093 which has a workaround.

    If you are not using CloudFlare, it may be caused by a plugin or theme conflict, the best way to test for these is to disable your plugins and use a default theme (such as Twenty Seventeen) and seeing if the problem persists. (We understand that may not always be an option, if you do not have a host that offers for example a Staging site that you can test things on directly, you may use the Health Check plugin, it offers a Troubleshooting Mode that lets you enable/disable individual plugins and themes for only your logged in session.)

    I used to get failed saved messages but no longer. But the saving mode is stuck on Gutenberg pages. The only way to stop it is to refresh. Everything is saved. But with any changes, saving to draft or publish “saving” mode continues to be stuck in cue.

    It was recommended to try Health Check plug in to see if any plugins are interfering. Any ideas?

    • This reply was modified 8 months, 1 week ago by  sharon135.

    I have been having no problem with this at home. Last week when posting from an hotel I had to give up and go back to the classic editor to complete the post.

    At home I have a very good broadband connection. In the hotel it was limited. Mobile hotspot was bouncing between 3G and 4G.the Hotel WiFi was passable but not great.

    It looked to me as if, due to the poor connection, the time taken to save meant that the autosave kicked in as soon as the previous save completed. The result was that the Publish / Schedule button was greyed out.

    No problem using the classic editor, but I did have to change the layout.

    No problem with preview, but every time I refreshed I lost the last change, particularly the schedule change and featured image.

    I had the exact same issue with editing a pre-Gutenberg published post. The edit window had been open for a significant period of time.

    What’s interesting is that the save session is in a continuous loop of failure, and it doesn’t autosave the published post. This is a dangerous destructive problem. I think the main thing to do is to close the edit window as soon as you’re finished — avoid accidentally leaving anything open.

    Fortunately I didn’t lose any content because I copied the content from the edit window and recopied everything over (formatting was copied successfully as well). I’m guessing that this problem is mainly with editing legacy content..

    self-hosted, WP 4.98, gutenberg enabled, Thesis theme, cloudflare on hosting

    I deactivated each plugin in order of activation and found that Site Origin Widget Bundle caused the “saving” mode loop. I kept that plugin deactivated and everything seems to be working fine. And My theme developer said the widget bundle plugin has a post carousel widget problem. If you turn that off in the Site Origin Widget Bundle settings it should make things work. It has to do with saving meta fields.

    I messaged Site Origin about this. They said the latest Gutenberg update broke the bundle function. They are working on a fix and will soon be updated.

    • This reply was modified 8 months, 1 week ago by  sharon135.

    That’s really useful. I’m using the carousel on one page si I can easily do without it.
    Thanks.

    Moderator Marius L. J.

    (@clorith)

    Hi all,

    This is a 3+ month old topic at this time, and each reply causes email notifications to go out to everyone, which can be conceived as spam after this long a time.

    In light of this, I am closing this topic, feel free to follow the tickets mentioned earlier, or create your own topics if you have further issues.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘‘Updating Failed’ Warning on Autosave?’ is closed to new replies.