Support » Fixing WordPress » Updating failed. The response is not a valid JSON response

  • Resolved Popeye1

    (@popeye1)


    Since updating WP Core to the latest version yesterday I am getting the error: Updating failed. The response is not a valid JSON response when trying to publish a new post.
    I have re-saved Permalinks, as per one suggestion.

    This okay T-P?

Viewing 14 replies - 1 through 14 (of 14 total)
  • Moderator t-p

    (@t-p)

    It may be a lot of different things: a plugin conflict either 1) a plugin doing something that creates output, thus breaking the response or 2) a plugin doing something stupid with caching), an overloaded server, misconfigured http/https address in General Settings, etc.

    By the way, did your site get auto updated to 5.6.1?

    Thread Starter Popeye1

    (@popeye1)

    Yes, I updated my three WP sites to 5.6.1 and all three now exhibit the JSON issue.

    None use the same theme, none use all of the same plugins. They are on three separate domain names hosted by HostMedia.co.uk

    Moderator t-p

    (@t-p)

    Try MANUALLY updating. Download WordPress again and unzip it, and use that to copy up. Access your server via SFTP or FTP, or a file manager in your hosting account’s control panel (consult your hosting provider’s documentation for specifics on these), and delete then replace your copies of everything on the server EXCEPT the wp-config.php file and the /wp-content/ directory with fresh copies from the download. This will effectively replace all of your core files without damaging your content and settings. (NOTE: do not delete the wp-content directory or your wp-config.php file). Please read the Manual Update directions first.

    Backup: If you haven’t already done, always backup everything (including your database) before doing any actions, just in case something really goes wrong. You can never have enough backups! See https://wordpress.org/support/article/wordpress-backups/

    Thread Starter Popeye1

    (@popeye1)

    Hello.
    I will do that now.
    However, for some reason, the JSON error triggers my web host to block my IP.
    So they are unlocking my IP every 10 minutes.
    Very tiresome.

    Thread Starter Popeye1

    (@popeye1)

    Replaced the files. Appeared to solve the issue but then the JSON error appeared again.

    Moderator t-p

    (@t-p)

    Thread Starter Popeye1

    (@popeye1)

    I’m reluctant to add a plugin to fix a system error.
    What I have discovered is that if I update an existing post I get the JSON error.
    If I create a new post I can publish it without an error.

    Thread Starter Popeye1

    (@popeye1)

    My web host says the JSON issue is a database error caused by a plugin.
    However, having deactivated all plugins, logged out and logged in again, the issue persists.
    In which case I’m currently guessing my databases on 3 sites have been corrupted by the 5.6.1 upgrade.

    • This reply was modified 8 months, 2 weeks ago by Popeye1.
    Thread Starter Popeye1

    (@popeye1)

    Further update.
    Not sure what’s changed, but I can now create and publish a new post.
    But I am unable to alter and re-publish an older – pre 5.6.1 post or page – as the JSON error appears.

    The Migrator plugin makes no difference.

    • This reply was modified 8 months, 2 weeks ago by Popeye1.
    Thread Starter Popeye1

    (@popeye1)

    Installing and activating the WP Classic Editor plugin has solved the JSON issue.

    Moderator t-p

    (@t-p)

    Glad its sorted 🙂

    Thread Starter Popeye1

    (@popeye1)

    wordfence, as well as cookie-law-info plugins are conflicting with 5.6.1 says my webhost HostMedia.co.uk

    Moderator t-p

    (@t-p)

    If you are using any of those plugins, please report the issue at their dedicated support forums so the plugin’s developers can take action as appropriate.

    Thread Starter Popeye1

    (@popeye1)

    Not sure what’s going on now really.
    Same post / page saves work. Others don’t.
    Now get occasional 403 pages appearing when trying to save a new post.
    I have multiple sites. All on 5.6.1; none use the same theme, some use the same plugins, all use a different combination of plugins, no sites are working as prior to the 5.6.1 update.
    I.e., they were all working without issue. now none of them are.
    The host and I have exhausted all options. Including disabling all plugins and using a WP Theme (2021). The JSON issue remains.
    Reinstalled WP 5.6.1 via FTP and within the admnin area.
    Have also installed a prior version of WP; no joy there.
    So I am exhausted after playing around with this for 4 days on and off.
    I’ll sit tight and hope I need to change nothing on the sites until the next WP miracle bug-fix update.

    • This reply was modified 8 months, 2 weeks ago by Popeye1.
Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Updating failed. The response is not a valid JSON response’ is closed to new replies.