Support » Theme: Pinboard » Updating failed. Error message: The response is not a valid JSON response.

  • Hi,

    After upgrading wordpress to 5.3 and Pinboard to latest 1.1.12 I can no longer update any pages.

    I am getting an error when click update:-

    “Updating failed. Error message: The response is not a valid JSON response.”

    Any ideas?

    Thanks,
    Allan

Viewing 15 replies - 16 through 30 (of 30 total)
  • Bijwerken mislukt. Foutmelding: De reactie is geen geldige JSON-reactie.
    I can make no changes at all after updating to wordpress 5.3
    the fixes on this chat do not help fixing my problem
    Can someone please help me out. Thx Mark

    Hello,

    Same here. Upgraded to 5.3 and now getting “Updating failed. Error message: The response is not a valid JSON response.”

    Strange enough, using the plugin Health Check & Troubleshooting, the results shows:

    Plugin Version Minimum PHP Highest supported PHP
    Health Check & Troubleshooting 1.4.2 — 5.6

    Php version 5.6??

    This problem started on one of my websites, when creating a new post

    The problem I’m encountering is creating new posts, new pages, editing new posts and editing new pages.

    Update: It appears my issues are adding javascripts and iframes.

    • This reply was modified 5 months, 1 week ago by johnramos.
    parag0906

    (@parag0906)

    Hi All,
    I am also new to wordpress. I had the same issue while adding or updating new page in localhost. I tried below step and get ride of it.
    1. Go to Settings->Permalink settings
    2. select option as post name.
    3. Save changes
    It resolves my error.

    @sanwar Installing classic editor plugin also solves my issue.

    On my case the .htacess have no write permission. I manually edit and included .htacess definitions show on the bottom of settings page, upload, and now is working OK!

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I had the same this morning. after a long researching I discoverd that on setting general the site addresses was both without https I dont know why those was changed and who did it but now all working good again.

    I also face this issue if a page contains an iframe.

    My iframe is embedded in a shortcode. I cannot save any page, which contain a shortcode, which contain an iframe.

    For example:

    onload="resizeIframe(this)"

    In my case I try to resize an iframe with the advanced-iframe plugin. The full shortcode looks like this:

    advanced_iframe src="https://xxx.com/script.php?parameter=value" frameborder="0" scrolling="no" onload="resizeIframe(this)"

    In an html block above I’v defined the resizeIframe method.

    <script
    function resizeIframe(iframe) {
      iframe.height = "10px" // required for reducing the size
      iframe.height = iframe.contentWindow.document.body.scrollHeight + "px";
    }
    /script>

    If I remove the part

    onload="resizeIframe(this)

    from the shortcode I can successfully save the page. With I can’t.

    I’ve tried already with disabled plugins and default theme.

    This issue seems to be related to
    In my case it https://core.trac.wordpress.org/ticket/48698

    • This reply was modified 4 months, 1 week ago by stidch.
    • This reply was modified 4 months, 1 week ago by stidch.

    Hi
    Same issue here however I have solved it in an odd way.
    I went to Settings – General
    Then
    Re-entered the WordPress Address with / after it
    Re-entered the Site Address with a / after it
    Clicked on [Save Changes] at the bottom
    The /s disappeared
    However when I went back to edit the page it would then save and everything seems fixed.
    Hope that helps someone
    M

    Had the same issue after updating Yoast SEO, reactivating of the plugin was helpful.

    Also try to go to Permalinks and just click Save (no change is necessary), that also may help to solve the issue.

    Hi all,

    its looks like. you need to use activate classic editor plugin
    if you are using any premium theme.

    and will be fine.

    Good Luck 🙂

    Toko Daring

    (@wpjakarta)

    Hello all

    you could try to write this code inside your htacces file
    just replace code inside #begin and #end wordpress

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    SecFilterEngine Off
    SecFilterScanPOST Off
    </IfModule>

    Hi all

    I am honestly at a loss with the issue I have… and I see it on so many forums.

    We have a website, its for a charity … it was quite happily allowing us to update pages etc… and it still allows a “Quick Edit” of a page…. but thats about it…. after that, any update used to get up until this morning the “Updating failed. Error message: The response is not a valid JSON response” .. and I have deactivated the plug ins … nothing…. the whole lot… I then updated this morning to the latest version of word-press… and now… the error note is replaced by a patronising “Updating failed. You are probably offline.”… no… Im not actually, I am online and this is the same issue yet no one can give a definitive answer as to what is causing it.

    When we look at the site health… there is the following message

    The REST API encountered an error
    Performance
    The REST API is one way WordPress, and other applications, communicate with the server. One example is the block editor screen, which relies on this to display, and save, your posts and pages.

    The REST API request failed due to an error.
    Error: cURL error 56: Failure when receiving data from the peer (http_request_failed)

    But, it doesn’t tell me how to repair it, or if indeed it is the source of my problem..

    Can I ask someone on here

    1 Since installing 5.4.1 has the Json error been replaced with “you must be offline” and if so why?

    2 Is the above the reason for not being able to update our site at all now hardly, if so, how or what do I need to do

    3 why does it keep saying that my theme is out of date… yet when I see the preview of the new one… its completely different and incorrect we dont like it and we want to keep our “theme”.. so why tell me its out of date????? I dont understand that logic

    I am grateful to anybody that could help… I am not playing damsel in distress … Im just very sad because it is so frustrating when you cannot think what to do… and we are getting to the stage where we just think it might be best to scape the site and find another host program

    Any help really grateful for
    yours
    distressed
    Claire

Viewing 15 replies - 16 through 30 (of 30 total)
  • You must be logged in to reply to this topic.