Support » Fixing WordPress » Updating failed. Error message: The response is not a valid JSON response.

  • Resolved sarseth

    (@sarseth)


    I’ve created my first post, about me page, customised everything.
    Then I’ve registered domain and assigned it.
    Now, when I’ve changed Site Address to the new domain suddenly I can’t edit posts. And this is the message I get.
    Updating failed. Error message: The response is not a valid JSON response.
    I can quick edit but cant edit by normal way.
    When I revert my ‘working copy’ address provided by bluehost it works perfectly.
    I’m in dark, since I cant find stacktrace ^^

    Found some similar issues, but always was considering attachments only. It’s not only for me and it is probably not broken by plugin, since I’m changing option in general.
    And I use only basic ones:
    Bluehost
    Code Syntax Block
    Google Analytics for WordPress by MonsterInsights
    Health Check & Troubleshooting – did not help
    Jetpack by WordPress.com
    OptinMonster API
    Yoast SEO

    • This topic was modified 2 years, 2 months ago by sarseth.
    • This topic was modified 2 years, 2 months ago by sarseth.
    • This topic was modified 2 years, 2 months ago by sarseth.
    • This topic was modified 2 years, 2 months ago by sarseth.
Viewing 15 replies - 16 through 30 (of 69 total)
  • Since several people (including me) are having this issue I doubt it’s a coincidence but rather an issue (bug) with WordPress.

    Is there a formal bug report made yet? (don’t know how this works here as I’m rather new..).

    edit:
    And why is this topic marked as resolved when there’s no confirmed solution yet?

    • This reply was modified 1 year, 11 months ago by nofish2.
    • This reply was modified 1 year ago by Yui.

    Using the classic editor (https://wordpress.org/plugins/classic-editor/) worked for me.

    me too, good luck!.

    for me it was conflicting plugin
    once deactivated all was good

    I just ran into this problem after updating to 5.3.2, found this thread and noted the problem with the URL.

    I checked Settings->General and saw that both WordPress Address and Site Address were set to http://www.xxx.xxx even though the site is SSL protected. I changed the http:// to https://, saved the settings, relogged into the Dashboard, and the problem is gone.

    Hope this helps.

    Make sure you have SSL certificate installed and enabled, that is how I solved it

    If you’re linux or unix(MAC) user

    1. check your “.htaccess” file from your wordpress folder is writeable
    If it’s not writable change writable permission. if not exist create it.
    New Gutenberg editor depend on .htaccess apache rewrite mode.

    2. At your wordpress admin page, Click “1)Settings 2)Permalinks

    3. choose “Post Name” from that page,
    You will see the “.htaccess” apache url rewrite settings in the textbox from that page.
    Click Save changes.

    4. Copy those apache rewrite settings and past into your “.htaccess” file.
    Then Save. Update and create your posts now. 🙂

    Wordpress new text editor(Gutenberg Editor) is OK in everything. Don’t need classic editor.

    Cheer!

    I ran into this issue because I renamed index.php to index-NEW.php while I was working the website. Once I renamed the file back to index.php the problem was fixed.

    I ran into the same issue.
    1) I did a permalink reset from Settings (changing from postname to plain and back) => links are still broken
    2) Modifiying .htaccess => links are still broken
    3) Using Gutenberg Editor => links are still broken
    4) Like mcwebsitedesign:
    Logging out. Chaging index.php to something else, like index-old.php; logging in; logging out; changing again to index.php; logging in => links are FIXED.
    You should check the wordpress database tables for integrity and for number of rows before and after the above sequence. It may be possible to lose some records.

    Matt

    (@reallymattgray)

    ASW got it for my issue.

    Try resaving your permalinks settings – Admin > Settings > Permalinks

    Upon (re)saving the existing permalinks settings, I went back to the post and it all saved correctly. Prior to that I had even opened up existing pages, updated (saved) them without any changes, and I was getting that error message.

    Thank you!

    Kindly check your .htaccess file and re-update it.

    Put it same as below:

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    I also get this error with yoast plugin, cant update/set meta tags or meta titles. Its wrecking my site.

    The site is hosted on Nginx so no htaccess file to fix. Check correct URL set in Settings – General, set permalinks twice, ran WP Optimize for database.. No luck yet. Any ideas how to fix it?

    I just installed 5.3.2 on a new website and right out of the box trying to create a page I get the error “Publishing failed. Error message: The response is not a valid JSON response.”

    Will WordPress ever fix this?

    I doubt that is a WordPress issue. Most likely a server issue of some sort. I know I have been having issues with ModSecurity rules running on my server not allowing the save function… Either that or nginx, which I removed completely from my server. Might want to ask your web host. If you need a web host let me know, I am fixing this issue today/tomorrow on my server.

    @mcwebsitedesign what MOdSecurity rules are you putting in place?

    I’m working with tech support on my host – I’, a hosting reseller, and spun up a 5.3.2 site yesterday for a new client and am getting this error. Going back to classic editor isnt an option for me.

    I have about 20 other installs on the same hosting, no issues at all, just in this new one! it’s really really annoying. I’ve never had so much trouble getting a WP site to work!

    Hi Nikola, I am still working with cPanel tech support staff to get this resolved. I believe we may have to come up with a customized rule set. Hoping to have this cleared up today.

Viewing 15 replies - 16 through 30 (of 69 total)
  • You must be logged in to reply to this topic.