Support » Fixing WordPress » updating Failed and publishing failed

Viewing 15 replies - 1 through 15 (of 28 total)
  • I have exactly the same on two websites I have

    Yes am having the same problem on one of our wordpress sites which got updated to v5. Theme used is District.
    Any advice appreciated.

    lisa

    (@contentiskey)

    Have you tried any steps in this guide:
    https://wordpress.org/support/topic/read-this-first-wordpress-5-0-master-list/

    Have you tried to install classic editor plugin to see if your post are editable?
    https://wordpress.org/plugins/classic-editor/

    Have you tried the health check plugin for additional troubleshooting?
    https://wordpress.org/plugins/health-check/

    I have installed the WordPress classic editor, and every thing works fine with me.

    I had the same problem but I don’t recall updating anything!

    Most of my website is built using Unyson Media Elements

    I cleared cache, updated all the plugins and deleted some old unused ones. I resaved my permalinks and then I installed the classic editor.

    I am not getting the same errors anymore for new edits.

    But the previous page I tried to edit is still mangled and not displaying correctly. Luckily I had a draft of it saved from last week when I was experimenting with something…

    dps102

    (@dps102)

    I got the same problem and noticed that in Health Check it said that I was accessing the site via https, but the address in my WordPress General setup was still http. I rectified the discrepancy and the failures went away.

    • This reply was modified 10 months ago by dps102.

    I fixed the issue by enabling the cron-jobs and without installing Classic Editor.

    cPanel -> Cron Jobs

    Settings:
    0 */6 * * * cd /home/replacethiswithyourown/public_html; php -q wp-cron.php

    I hope this helps!

    None of these fixes worked for me on my site, what am I doing wrong?
    https://www.bestrestaurantschester.co.uk/ I’m getting quite frustrated with WordPress since the latest editor update! Hmph.

    By just looking at your website, I don’t know the issue.

    Other forum said, change the permalink to ‘day and name’, or you can change it to ‘post name’. Other also mentioned, install a health check plugin to see if it’s an issue with the REST

    Have you tried installing a plugin called “Classic Editor” or “Disable Guttenberg”?

    *btw, great looking website there!

    blackvision

    (@blackvision)

    What is the actual solution? This error sucks! I cannot save or update the posts. The site website was working fine before the 5.0 update and now I cannot add posts.

    Victoria Clipper

    (@victoria-clipper)

    I just did a complete fresh install (from Ubuntu all the way up to WordPress 5) and ran into this error. Apache log file showed “search permissions are missing on a component of the path” to /wp-admin/admin-ajax.php. So I reviewed my config and discovered I had forgotten to enable .htaccess using:

    <Directory /var/www/internal/>
        AllowOverride All
    </Directory>

    Restarted apache and everything works like normal now. Not sure this would be the cause for all the above errors, but hope it gives a clue!

    mhsofts

    (@mhsofts)

    I am also fetching the same problem in my website http://blog.mh-softs.com

    In my case this is mostly to do with post urls.
    This happened when i changed WordPress Address (URL) to a .cn domain and leaved the Site Address (URL) to still be my ip.
    I just changed the 2 urls to be the same, the .cn domain and it went away.
    Among other solutions i found many are also about format of urls so maybe look into that in settings.
    And ur php error log may also be helpful.

    Temporal solution!!

    I had the same problem. To fix it I just went to Settings – Permalink, and set it “Plain”, that is http://yourdomain.com/?p=123

    This is a temporal solution because I don’t like this setting, I usually use “Post name”.

    I realized when I checked the error log in the server, and I found a “File does not exist” error, refering “http://mydomain.com/wp-admin/post.php?post=16&action=edit&#8221; as the file.

    Changing the permalink setting didn’t work for me.

    This has been going on for months. Why hasn’t been fixed?

    In my case it’s intermittent. Sometimes a post will save, sometimes it won’t. Sometimes it’ll stop saving partway through previewing a post. The only solution is to log off and log back in.

    So now I have a 400 word post that won’t save. The only option is log off an lose it then came back in and try again. I’m starting to get seriously pissed off with WordPress.

Viewing 15 replies - 1 through 15 (of 28 total)
  • You must be logged in to reply to this topic.