Support » Plugin: User Access Manager » Updating database broke site

  • The plugin had been updated several days ago and is now at 1.2.8. I had not updated the database until tonight. After updating the database, only one post showed for the blog. All others were unavailable and had “Administrators” group marked for access but disabled so I could not turn it off. Pages seemed to be displayed properly, but I did not check all of them.

    I ended up having to restore my database from backup.

    My settings include Protect Feed (yes), Hide empty cat (yes), Redirect user (no), Lock recursive (yes), Show admin hint (yes). These are the same settings I have been using all along.

    The ‘Administrator’ name is set to Administrator access only, only group users, only group users, editor, none.

    I appreciate any suggestion on how to fix this.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author GM_Alex

    (@gm_alex)

    Hi guy without the update the plugin will not work properly, so you muss configured the plugin and see the right config after the update which seems not the thing you wanted. I think the posts are locked by the categories. Update the database and disable recursive locking.

    On question: Whyis the update of the database such a big deal that everyone is afraid of? Is the hint about the backup the problem?

    Still not working with recursive lock off. I have a group named Administrator. After running the update, all posts but one have the Administrator flag set (which restricts viewing to admins). When I edit such a post, the Administrator group is dimmed and will not let me change it.

    Another oddity I see is that when I show posts/categories, the counts for almost all categories is 1. Yet if I click on the ‘1’, I do see all the posts in that category. A few categories show the proper number of posts but most just say 1.

    You ask why update of the database is such a big deal? Because of problems like this that break the whole site. I’ve been burned several times by database updates by various plugins, so am intensely cautious when one is requested.

    Plugin Author GM_Alex

    (@gm_alex)

    The not clickable check boxes still sound that something isn’t set up probably and with out the database update the plugin will not work correctly.

    Where is the count invalide at the backend (admin pages) or the front end?

    Also the database setup will not change something big it just changes the naming, so if it worked with 1.2.7.2 and before it still will work. I you create me an account at your page I can have a look what’s not working, best would a account for a test environment.

    Plugin Author GM_Alex

    (@gm_alex)

    Any update on this?

    I want to set up a test environment and that is taking a little time to do.

    Plugin Author GM_Alex

    (@gm_alex)

    Ok. Thanks for the feedback.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Updating database broke site’ is closed to new replies.